PA-28-181 Archer III

16 Topics 52 Posts
  • This topic is deleted!

    1
    0 Votes
    1 Posts
    2 Views
    No one has replied
  • Are the issues with the Archer III fixed now?

    1
    0 Votes
    1 Posts
    95 Views
    No one has replied
  • Nose wheel Steering Issue

    1
    0 Votes
    1 Posts
    68 Views
    No one has replied
  • Does not hold correct altitude

    6
    0 Votes
    6 Posts
    266 Views

    Thank you for your replies. I thought I had created a ticket but checking I cannot find one regarding this issue. So I will take your advice and create a support ticket for this issue. Thank you.

  • Right Magneto cuts engine

    2
    0 Votes
    2 Posts
    315 Views

    I have discovered the following events control the magnetos:

    Right Magneto = LEFT_LOWER_magneto_right (LVAR)
    Left magneto = LEFT_LOWER_magneto_left (LVAR)

    However I do not know how to configure this, knowing this information!

  • Mapping Radio Master button

    2
    0 Votes
    2 Posts
    374 Views

    I've managed to discover that the switch is controlled using RIGHT_LOWER_avionics_pwr (LVAR). However if somebody could explain how that's configured in SPAD or FSUIPC, that'd be good.

  • 0 Votes
    17 Posts
    7k Views

    @Wiggi001 That's your opinion and no problem with that. It's been checked here again and we can't reproduce the issues using the latest build (from Nov 19), the FDE seems fine.

    But if it doesn't work as you'd wish and that will mean you won't be using the aircraft then please contact the support team who will be happy to issue you with a refund. This Archer has been very well received since release and has become a favourite add-on for many users. However we'd not want anyone sat on an aircraft they can't use so please feel free to do as I suggest above and claim your refund.

  • 0 Votes
    3 Posts
    1k Views

    Just in case anyone is looking for it, it seems to be right under the control column.

  • 0 Votes
    1 Posts
    928 Views
    No one has replied
  • Autopilot does not hold altitude

    3
    0 Votes
    3 Posts
    2k Views

    Just to be clear in case someone reads this, it is not fixed in 1.03. I was mistaken. I opened a ticket and I think it is in a stack of fixes for the next update. Timing of update unknown.

    Workaround is set A/P vertical speed to zero. That works.

    Rick

  • CTD on Startup , Panel Selector and AP problem

    4
    0 Votes
    4 Posts
    1k Views

    @Derek Thanks, Derek. I will contact your support.
    Felix

  • GTN 750 settings not maintained

    2
    0 Votes
    2 Posts
    1k Views

    Same problem here and strangely no reply since April 25. Does anybody NOT have this problem?

  • Archer III battery will not charge

    2
    0 Votes
    2 Posts
    1k Views
    No one has replied
  • Squawk code in the Archer on the GTN 750

    1
    0 Votes
    1 Posts
    1k Views
    No one has replied
  • 0 Votes
    5 Posts
    3k Views

    I have the same issue with the cruise speed and sent a ticket yesterday about it. In real life I fly warriors with 160 HP engines and no wheel fairings. 2500 rpm gives a TAS of about 110 knots. In the JF Archer I can barely reach that speed at normal power settings, and can only reach 115-120 KTAS if I firewall and over speed the prop in cruise. Keep in mind the archer has a 180 hp engine and wheel fairings, so it should perform better than the warrior, not worse.
    This is in FSX boxed with windows 10

  • This topic is deleted!

    1
    0 Votes
    1 Posts
    5 Views
    No one has replied