PA 28R ARROW III for MSFS "Security Failure"

  • @Frank-G , yep same here, steam version of msfs?

  • bought this yesterday with my msfs version, i got this message when I rename the folder "justflight-aircraft-pa28-arrow-iii" inside community folder. after I change it back it works.


    You have Steam and MS store version installed? If so, then copy userinfo.txt from:

    AppData\Roaming\Microsoft Flight Simulator\Packages\justflight-aircraft-pa28-arrow-iii\work to

  • @Cygnific I found this post to and tried to fix the error with it, unfortunately there is no Userinfo.txt in
    AppData \ Roaming \ Microsoft Flight Simulator \ Packages \ justflight-aircraft-pa28-arrow-iii \ work
    AppData \ Local \ Packages \ Microsoft.FlightSimulator_8wekyb3d8bbwe \ LocalState \ packages \ justflight-aircraft-pa28-arrow-iii \ work
    does not exist at all. And yes, I chose the right User. Unfortunately, I have still not found a solution, since my purchase I opened a ticket, but unfortunately I still have no reaction from support.
    If they offer me a solution that works, I'll post it here to help you all too, if not, I'll just request a refund, although I don't want that because the PA28R is really in good shape, it just has to work: - )

  • @Cygnific
    MS Store version.
    in AppData \ Roaming \ Microsoft Flight Simulator \ Packages.... is no \ justflight-aircraft-pa28-arrow-iii Folder and in the
    AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\justflight-aircraft-pa28-arrow-iii\work Folder is no userinfo.txt

    my english is to bad for a ticket but when no solution is coming, i want my money back

    I tried several new installations, there was never a message that the process was finished. Registration was only requested during the first installation.
    it is the first time that i have such problems when installing an addon, otherwise it always affects the others

  • JF Staff

    Whilst this is not a support forum, please submit all bugs to the below link

    If you haven't already, please take a look at the FAQ for this aircraft below

  • @Shado2k I have the Steam version.

  • @Thrunkx @Steffen1030 Any change if you run the installer with Administrator? It should get the install path from UserCfg.opt (A problem when you have two versions installed and it only reads one)

  • @Cygnific No, no change, still can't use the PA-28R, I've tried everything I knew, but unfortunately without success.
    I started the installation as admin from the beginning and even later I gave myself super admin rights to make sure that it wasn't because of that, but as I said, unfortunately no result.
    Then I did a readout and sent the support but unfortunately I haven't gotten any reaction from them so far, I'm slowly losing interest in the plane and I'm starting to think about asking for the money back.
    I have been waiting for a solution since Saturday and have not been able to test the aircraft until now.
    My readout:
    Checking for MSFS installation
    Checking for steam version
    usercfg.opt file located
    C:\Users\Thrun\AppData\Roaming\Microsoft Flight Simulator\usercfg.opt
    reading usercfg.opt file
    InstalledPackagesPath entry found
    InstalledPackagesPath "N:\Packages"

    package path - N:\Packages
    configs path - C:\Users\Thrun\AppData\Roaming\Microsoft Flight Simulator
    working path - C:\Users\Thrun\AppData\Roaming\Microsoft Flight Simulator\packages
    flights path - C:\Users\Thrun\AppData\Roaming\Microsoft Flight Simulator
    official path - N:\Packages\Official\Steam
    sdk path -
    Updating registry settings

  • @Thrunkx

    You have some weird folder structure. N:\Packages Have you tried to rename it N:\Microsoft Flight Simulator? Dont forget to change to the same foldername in UserCfg.opt

  • @Cygnific yes I tried that too, because MSFS is already 617GB with me, I created a new livery on Steam only for MSFS that is used on an external SSD hard drive. the structure you see there is what Steam created when I installed MSFS on steam.

  • @Thrunkx So N:\Packages\Official\Steam is where all your MSFS data is stored now, and N:\Packages\Community is where the community add-ons are stored?

  • @Cygnific yes

  • @Cygnific Actually that’s a common structure if you install the Steam version of MSFS to another harddrive. The “official” and “community” folders will install to the other harddrive, while the MSFS executable and other folders will install to steamapps/common/microsoftflightsimulator. This is similar to what I have, and I suspect Justflight’s installation or license check does not account for this somehow.

  • @Gilandred yes that's exactly what I think

  • Here is my structure for reference.

    Checking for MSFS installation
    Checking for steam version
    usercfg.opt file located
    C:\Users\Owner\AppData\Roaming\Microsoft Flight Simulator\usercfg.opt
    reading usercfg.opt file
    InstalledPackagesPath entry found
    InstalledPackagesPath "F:\MSFS"

    package path - F:\MSFS
    configs path - C:\Users\Owner\AppData\Roaming\Microsoft Flight Simulator
    working path - C:\Users\Owner\AppData\Roaming\Microsoft Flight Simulator\packages
    flights path - C:\Users\Owner\AppData\Roaming\Microsoft Flight Simulator
    official path - F:\MSFS\Official\Steam
    sdk path -
    Updating registry settings

  • @Gilandred Yes I know, was just wandering why it would be called Packages instead of something like Microsoft Flight Simulator.

  • I think more people would complain if it was a Steam AppData\Roaming problem and they only check AppData\Local.. But who knows. 😃 You can check that by making a folder in Appdata\Local

  • @Cygnific During the installation process MSFS will let you install it to a folder of your choosing so your able to name it whatever you want. Looks like this might be the common issue for installation issues, but is not terribly widespread as I suspect most people use only one drive.

  • @Gilandred I doubt, the folder is written correctly in UserCfg.opt and that is checked by the installer. My problem was that it only read the AppData\Local folder and forgot the AppData\Roaming where I have another install for Steam.. (I have Store and Steam versions installed).