BAe 146 Professional P3D v5 FMS/AP Issues



  • Hello all,

    Having recently purchased the newly released Just Flight BAe 146 Professional P3D I am disappointed to report on some rather glaring issues in the aircraft's FMS system that impact upon the fundamental aspects of flight planning.

    To start off with, when trying to select waypoints, by clicking the LSK next to them as mentioned in the accompanying FMC manual, you should be prompted with LSK 1R (DEL) and LSK 2R (INFO) when clicking the waypoint you want to select, it simply flashes for a mere instant and does not do anything, therefore you are unable to delete or insert waypoints mid-flight without completely deleting the Flight Plan and starting from scratch.

    Just when I thought that I'd narrowed this bug down and decided that I can live with it now, albeit with a support ticket to JF support inbound, I came upon another basic error within the FMS. When trying to select a departure from EGBB, following the workflow of clicking MENU > DEPART , selecting Runway 15 by typing in 1 and pressing ENTER, when selecting SIDs I am unable to select any of the SIDs that aren't 1 or 2 in the list, it simply will not even enter any other number from 3-9, even when the box is highlighted white, so effectively, unless your SID happens to be one of the first two listed for your particular runway, you're stuffed!
    (As a sidenote to this, I have found that if once you encounter this problem you click FPL to get back to your legs page, click MENU > DEPART again, all the SIDs have remarkably vanished unless you type in which Airport and Runway you'd like to fly a SID for is re-entered, despite them already being in the boxes, and essentially re-entering the same text)

    Next issue on the list is a strange one, on occasion, when trying to enter a next waypoint in the FPL page, for example entering the waypoint 'LUVUM' after our departure airport 'EGBB' in the list, it will bring up the AIRWAYS from EGBB page despite us entering a waypoint (LUVUM) to fly straight to after leaving EGBB. There is no way around this, so it basically prevents you from putting any waypoints in.

    Sometimes the keys to the side of the FMS e.g. FPL, MENU, NAV, PREV/NEXT don't work despite them should be able to work, e.g. I was on a certain page which had 1/2 at the top, and despite pressing NEXT nothing happened.

    These are my initial observations, and yes I have submitted a ticket, just thought I'd share it with all you prospective users/buyers.



  • My Fms is not powering up, no mouse click spot on the power on button. Will try to re-install tomorrow



  • Evening all, just to add to Morgan's post I am also having issues with the FMS/AP, after my departure I switched into RNAV mode and engaged LNAV. The aircraft just freezes and will stay at whatever bank it was in when LNAV was selected. The aircraft does not track any way points even if directed to by using the DTO function. Also when in LNAV mode the HDG Select bug actually moves the course and not the HDG bug. The IAS function on the AP does not appear to be functioning at all as when selected the aircraft makes no attempt to pitch to maintain speed.

    Other than that the only two minor issues are the master caution warning will stay on even when battery and all elec sources are disconnected & cannot be cancelled unless the battery is switched back on. Finally the N1 rotation seems to take a while to slow down after engine shutdown it just feels a little un-natural or maybe its just me ?

    Nothing else to report other than shes an exceptional aircraft & I'm really impressed with your work !

    Kind Regards Harry.



  • +1 to all of the above issues, I've experienced the same.

    -HDG bug tied to CRS in RNAV HSI Mode.
    -IAS hold autopilot mode (FL Change) seemingly not doing a lot.
    -RNAV/LNAV not seeming to follow plan. (CDI in RNAV mode does not centre, even after a DTO from the FMC - I'd expect it to draw a PPOS DCT XXX Fix)
    -In the FMC upon selecting DTO a fix, it seems to delete all previous fixes in the flight plan (Could be pilot/PEBKAC error/design feature - but frustrating nonetheless, as I was trying to figure out the previous RNAV issues I was having and ended up having to jump to the next waypoint in the sequence)

    I also am now having some activation errors that I have detailed in another post and am unable to fly the plane.


  • JF Staff

    Hi all,

    Thanks so much for all the feedback and clear/concise bug reporting. This is our most complex aircraft by a long way and we're eager to continue to improve it with not just bug fixes but additional features.

    We are working through all the feedback and the first update will be available shortly.

    Thanks
    Martyn



  • @Martyn said in BAe 146 Professional P3D v5 FMS/AP Issues:

    Hi all,

    Thanks so much for all the feedback and clear/concise bug reporting. This is our most complex aircraft by a long way and we're eager to continue to improve it with not just bug fixes but additional features.

    We are working through all the feedback and the first update will be available shortly.

    Thanks
    Martyn

    Hi Martyn, that's fantastic news I look forward to the update! & thank you for all your hard work. Kind Regards Harry


  • JF Staff

    And here's a change log for the first update:

    • MWS cautions triggered with electrical power off - fixed
    • 300QT ASL airlines livery - fixed
    • Improvements to spray effect
    • Autopilot not following FMC route with LNAV engaged - fixed
    • Heading bug not settable with LNAV engaged - fixed
    • Minor changes to FDE
    • Improvements to exterior glass reflectivity
    • Changes to security validation to reduce risk of failure

    Thanks
    Martyn


  • JF Staff

    @morganthomas757 And thanks for the comprehensive feedback on the FMC logic. Our FMC developer is looking into all of those points now.


  • JF Staff

    And for those that are eager to get into the air now, you can download the v1.1 update zip here if you're comfortable installing it manually - http://tiny.cc/ajn5tz (updated 1444z)



  • I agree with all the issues above. Thanks for the quick update, I will try it out.

    In addition to what was mentioned, I have the following issues:

    1. In the VNAV page of the FMC I was unable to go to page 2 (FMC indicated there were 2 pages, but unable to go there).
    2. It's not possible to set the altitude/FL for any waypoint in the FPL page.

    Besides these issues (that make the plane nearly impossible to fly properly), I really like the simulation of the BAE 146 and am confident these issues will be solved.

    I fly the P3D 4.5 version.



  • Cannot believe I have just spent £60 on something that clearly has not been tested correctly and is unflyable in my eyes. The FMC has no click spots and is INOP. I can see people having issues are mainly using p3dv5 maybe that is somewhere to start?


  • JF Staff

    The FMC is by no means essential for flying the 146 and wasn't original navigation equipment, although we appreciate that it's many simmers navigation method of choice, and we will of course address any issues.

    We've had no issues with the FMC controls during extensive testing and that's not a known issue so please submit a support ticket so we can investigate further. The FMC should certainly be operable and has been used to fly many test flights in both v4 and v5 so something is wrong beyond anything more specific issues mentioned above.

    Thanks
    Martyn



  • I’ve got an issue with the font in the FMC, which seems to be too large to fit on the screen. Should I also submit a ticket?

    0523C8D0-1576-4CE1-B3D1-C3E0E08AA135.jpeg


  • JF Staff

    We are already looking into the font issue that some people are encountering so no need to report that one. A fix will be made available ASAP.



  • Firstly, well done on this brilliant plane. Great all round and I am confident it will get better.

    A few things that I have had trouble with on the tutorial flight:

    1. Config test never passes, after going through everything in the tutorial I am not sure what is not configured. But I went through it several times already now. and did the flows from scratch but none the less the alarm still sounds on the config test.
    2. Return flight, aircraft did not allow any yoke inputs mainly pitch and roll, AP was off. Rudders worked fine, both are set to the joystick for control. Would be great to know what the config test looks for so we can check those items.
    3. Using active sky weather, the aircraft had difficulty staying on course while following a direct to VOR, constantly adjusting left and right even when far out.
    4. I believe there is a "flash light" feature from your preview videos, unsure how to turn that on.
    5. Flight dynamics: aircraft seems fairly sensitive to inputs when hand flying, sudden fast jerk up or down pitches.
    6. APU exterior sound is fairly quiet.
    7. Suggestion: A tutorial video, so that newcomers can get a better visual of flows and where things are located.

    I have only done a couple flights without the FMS but will give that a go next week.

    best,
    Philip



  • Re-installed a few times still no click spots on FMS to even turn it on. I am wondering if the flight1 GTN750 will work. This is the very first just flight product at launch I have ever had a serious problem with.



  • Hello

    after flights with V1 and V1.1 I have the following feedback/problems (P3D5.1hf1):

    • I like the plane in general, nice exterior and cockpit (but why worn off switchbutton on NAV1?), very nice cockpit lighting, realistic sound.
    • FMC: select SID - I can only choose 1 to 4, if more SID are available, I can not enter or choose 5 6 7 8...
    • LNAV in 1.1 usable, but for my taste overshoots waypoints too much, struggles to come back on track.
    • same or similar with the ILS interception... LOC and GS... don't know why it strggles or turns the wrong way - will try again
    • Trim: very sensitive, I have a joystick button assigned, wish there was half the rate for changings.
    • Mouse scroll wheel - for my taste it should behave the opposite way (as used from other planes). Or can it be changed somewhere?
    • Turning knobs: is there a key for turning faster? normal 1 click 1 step / accellerated 1 click 10 steps
    • AP/ALT: leveloff 100ft below selected ALT
    • would be nice to have [shift+8] for a pop up window of center console (AP/XPDR/Brake)

    greetings
    msair



  • I've had fun trying to enter the STAR for LHBP. See below:

    No STARSs are available, just the approaches and RNAV transitions. In this case I was trying to use the ANEXA 1H arrival for ILS 31R
    2020-11-28_20-40-6-821.jpg 2020-11-28_20-39-57-332.jpg



  • I used the first update for my second flight. The issue of AP not following the FMC or VOR inputs is solved 🙂 . So I was able to fly the flight and do an ILS approach into LMML.

    The issues with the FMC are still there (as expected, can imagine it takes longer to fix). At least I am able to turn on the FMC and use it is some way. But personally, when paying € 75 euro's for this package, I don't expect these issues. And yes, you can fly the plane without using the FMC, however i bought a product Including an FMC. Sure for this money. So I am not entirely satisfied.

    And as I only fly on Vatsim and the Com radio's don't come active in Vatsim (see my other topic), it is pretty much a useless product for me at the moment.



  • @Martyn said in BAe 146 Professional P3D v5 FMS/AP Issues:

    And here's a change log for the first update:

    • MWS cautions triggered with electrical power off - fixed
    • 300QT ASL airlines livery - fixed
    • Improvements to spray effect
    • Autopilot not following FMC route with LNAV engaged - fixed
    • Heading bug not settable with LNAV engaged - fixed
    • Minor changes to FDE
    • Improvements to exterior glass reflectivity
    • Changes to security validation to reduce risk of failure

    Thanks
    Martyn

    I downloaded the patch made available above, and have similar issues as the others.. Additionally, with regards to the "Improvements to exterior glass reflectivity" line item, tbh, doesn't look really different to the release version. It's pretty much the exact same. There's no depth and color tot he surface. There are a TON of pictures on the internet showing this, but I'd be happy to find a few if it helps correct this. It really looks strange without it.

    Thanks!