New development build


  • JF Staff

    Hi all,
    A new development build of Traffic Global has been posted in the Early Access forum.
    https://traffic.justflight.com/topic/999/traffic-global-1-1-1-4

    This new build includes new cargo and GA traffic generation. See the forum page for full details and instructions.

    Note - currently this build is only available from the Early Access forum. The link in the My Orders page in your JF account will currently serve an older build until v1.1.1.4 has been proven stable.



  • @Rich
    Thanks for that Rich (& all the many other folk who contributed to it).
    Hope all of you at JF are doing ok.
    (Having finally managed to shove my pc bits back together in a new case and reinstalling everything after finally losing my rag with Win10, I look forward to playing around with the new build one day when I've managed to get FSX up and running again)😁
    Stay Safe!

    Frank



  • @Rich
    Hi Rich
    Downloaded TG v1.1.1.4exe and followed the instructions you posted in the EA Forum regarding the installation procedure but received the following InstallShield Wizard Error window:
    91304bf3-5617-43bb-b1f3-5ffb3b358045-image.png
    7ee847ec-04f9-4846-a669-9b3280ccc2af-image.png

    (Sorry I had to post two images of the error window in order to capture the full error message detail)

    Also, the download size of v1.1.1.4 is only 11,863KB vs. 1,307,580KB for v1.1.1.2? Does that seem right?

    Unless I'm completely misunderstanding the instructions that you posted in the EA Forum regarding the installation of this build, I downloaded v1.1.1.4 from the link you posted, unistalled v1.1.1.2 in the usual way, (running the .exe in admin mode, which also removes the \Documents\TrafficGlobal\TrafficGlobalFleet folder that you indicated would require manual deletion) then attempted to run the v1.1.1.4exe again in admin mode, but was presented with the InstallShield Wizard error window images posted above.

    Possible that I've somehow misinterpreted the instructions that you posted in the EA Forum, but wanted to just advise as you requested in the event that I haven't.

    Thanks Rich


  • JF Staff

    @vortexwake
    Hi,
    The download should be over 1.4Gb, so it sounds like you got a corrupted download there. Try grabbing the file again and see if you have better luck.



  • @Rich
    OK thanks Rich
    Will give it another try and advise



  • @Rich
    OK that DL came in at 1,459,781KB's
    Will run through the installation again.

    Thanks Rich



  • Uninstalled the previous version through Control Panel. Installed this version in P3D v4.5 as an administrator. Running the compiler with just the box for Traffic Global Flight Plans ticked. The compiler has been running for some 15 minutes so checked the Task Manager and it shows:

    Traffic App (32 bit) running at 0%

    Should the Traffic App not be 64 bit? And does it normally take this long to compile as I am sure that previous versions did not take this long.

    John



  • @may433
    Uninstalling/reinstalling should only be done using the TG installer by running the .exe of the older or newer version of TG. Using the Control Panel function to remove an older version of TG can leave remnants of the older version behind in the registry that can lead to problems when trying to reinstall an updated or newer version of TG.

    This may result in the 'hang time' that your seeing while trying to complete the compiler process.

    Using the Task Manager to force a stop of the compiling process will shut the TG UI down and allow you to attempt it again, but you may have to run the TG .exe again first, in order to remove any trace of the older version before reinstalling the latest version, (v1.1.1.4) and then running the compiler process again.


  • JF Staff

    @may433
    Hi John,
    Could you give it a go and verify that you've selected both the TG flight plans and also P3Dv4 in the sim selection window.
    Also could you set the rest of it up in this configuration:

    tg.png

    All being well, that should compile in five minutes or so. Whilst its doing it's work, you should see it taking up a noticeable chunk of CPU % in the task manager. If it's sitting at 0% then it's probably hung up on something.
    Note, the commercial traffic part of the program hasn't changed yet. It is being worked on at the moment, but the main changes are the cargo and ga modes, so I'd recommend compiling them as well.
    The app should be running as a 32bit program.



  • I've just finished completely reinstalling FSX (boxed), FSX-SE and TG v1.1.1.4 from scratch and compiled the TG traffic (airline, cargo & GA) all of which went without a hitch....but....

    the following models seem to be invisible in FSX & FSX-SE in both dx9 & dx10 (just to confirm this, I loaded them all as flyable aircraft with the same result):

    B58 Baron
    B36 Bonanza
    C152
    C208 Grand Caravan [error msg: 'visual model could not be displayed']
    C172 Skyhawk [error msg: 'visual model could not be displayed'] [all fltsim entries have ui_type="C152" in aircraft.cfg]
    C550 Citation
    B200 Kingair [error msg: 'visual model could not be displayed']
    Piper Cherokee

    the Learjet appeared ok though🙂

    the only other time I've seen this (or..not, in this case) in FSX is when there's a 64bit model used which could not be displayed in a 32bit program.



  • Rich,

    Thanks for the prompt response. Tried it exactly as your screeenshot but this time I got the unhandled exception message saying

    Access to the path
    'C:\Windows/system32\systemprofile\AppData\Local\MicrosfotWindows\NetCache\Content.IE5' is denied

    I have reverted to the previous version for the moment.

    John


  • JF Staff

    @Capt-Quirk

    Thanks for the report. I've just fixed this and added the files to a new installer. As we're heading into a holiday in the UK I'm not sure if my colleague with the keys to the upload server is going to be around in the next few days though. If it's not sorted soon I'll send you a link to where you can get the updated MDL files at least.

    @may433
    That's a strange error message. Content.IE5 isn't something that I reference in the code. It might perhaps be something that I do use then uses itself, but I've no idea what that could be. Was that path copied exactly? It has a slash going the wrong way and some garbled info in the middle. If that is a literal report of the error then it might be that there is a Windows reg entry with some bad data in it.



  • @Rich This is a screenshot of the message. My typing error in my last entry - sorry

    TG Install problem.jpg



  • @Rich
    No worries, Rich....thanks for the quick fix. No rush for the upload given the current situation!
    Hope you have a safe and happy break from 'routine' (whatever that is these days😁 )



  • @Capt-Quirk
    Hi CQ
    Just following the post traffic between you and Rich. So Rich has corrected the missing MDL files and set up a new installer for them, but the installer still has to be uploaded to the server, and this may not happen over the course of the Easter weekend due to the holiday? Do I have that right?


  • JF Staff

    The new installer is up now. Just go to the EA Forum and grab it from there: https://traffic.justflight.com/topic/999/traffic-global-1-1-1-4/2



  • @Rich
    Thanks Rich



  • This post is deleted!


  • @Rich
    The DL is still listed as 1.1.1.4 (1,455,788KB....vs. 1,459,781KB of the original DL)
    Should it have been displayed as 1.1.1.4/2 as per the link? Or is it just the way it's uploaded?
    Also, should the same installation instructions be followed that you posted for the original DL?

    Thanks Rich



  • Hi Rich,

    I've just downloaded the update/fix & uninstalled/reinstalled and am happy to report that the some of the planes are now visible in a completely clean install of FSX-SE (dx9):

    Baron B58 still invisible, no lights and tends to taxi off the airport into the undergrowth
    Bonanza B36 still invisible
    C152 OK! but all the repaints are the same!
    C208 OK!
    C172 Skyhawk OK! but, again, all the liveries are clones
    Citation nope, still can't see it
    Kingair B200 OK!
    Piper Cherokee 140 doesn't appear to even load into the sim

    [Since this was only the results from a cursory test of flightplans created to park the planes up in a deserted airfield, I may have missed some other issues as I've not yet parked up all the repaints for each individual aircraft] Hope that's of some help, anyway.

    Is anyone else is having similar problems, or are my cataracts a lot worse than I thought🤓 ?