Still stuck with Cargo while Compile P3dV5 with v1.1.1.8



  • Still stuck with Cargo while Compile P3dV5 with v1.1.1.8
    Any help?



  • Same problem here with P3Dv4 HF2



  • Have you tried only compiling Cargo flights, uncheck all the other boxes, mine compile ok P3Dv5.



  • Yes, but with the same result - hangs on generating cargo flight plans. But thanks for the suggestion!



  • FSX-SE user. v1.1.1.8 still hanging on compiling Cargo flights no matter which way I do it.





  • I had this problem and the only way to fix it for me was the nuclear option. I formatted my drives, installed Windows 10 2004, reinstalled P3Dv5, but I added all add-ons methodically, testing each one to find a culprit causing this to happen. I never found out why it happened in the first place. But now all works fantastically.

    I'm sure many people don't want to go down this route, but it worked.

    Regards.

    Simon B.



  • I had this same problem in the previous two versions of TG.
    In the case of v1.1.1.6, compiling cargo separately did work after uninstalling/reinstalling TG.
    This method did not work for v1.1.1.7 and neither has this solved the issue for me in v1.1.1.8.
    No matter which variation of compilation I use, the program hangs here:
    TG v1.1.1.8 Cargo Flights hanging.jpg
    In fact, the program appears to be looping, as it is still generating cpu activity but, having run it several times for extended periods with a variety of compilation selections, in no case did the program complete.

    This only occurs when compiling Cargo flights. Both Airline and GA work fine, generating larger traffic filesizes based on installed scenery.

    Noting that Mr Fry's video shows that he has 'My AI Flights' ticked rather than 'Traffic Global Flight Plans'
    TG v1.1.1.8 RF Cargo compile.jpg
    I also tried that same combination of selections and, for me at least, the program appeared to hang at the same point as before.
    [Of course, a few cargo flights do appear in the sim as there is a 'default' traffic file of 2.55Mb placed into my scenery/world/scenery folder when installing TG].
    Alternatively, maybe it's just taking it's sweet time regenerating schedules or something so I'm currently just leaving it compiling to see if it will ever actually complete. [EDIT: nope, just passing 1 hour and nothing happening!]



  • Same Here !!



  • Thought about Simon Bs suggestion (thank You!!), but I didn`t want to make a full reinstall of P3Dv4 - 1.1.1.7 was my last working version, so I removed any scenery addon that i had installed before 1.1.1.8 and reinstalled Traffic global and everything is fine! I do not know, which addon was the culprit...

    Best regards

    Timo



  • @businessflyer hi there, what add-ons did you have installed?

    I'm wondering if we can narrow it down a bit.

    Regards.

    Simon B.



  • @Simon-B

    Good idea! These are the mentioned addons (all for P3Dv4):

    • Aerosoft Mega Airport Rome
    • Aerosoft Milano-Malpensa
    • Aerosoft Napoli X
    • Aerosoft Erfurt
    • 29Palms Nürnberg
    • Digital Design Leipzig-Halle
    • Justsim Hannover

    Best regards

    Timo



  • @businessflyer

    Well that's a bust 😅 I have non of those and I'm on P3DV5. Oh well was worth a try.

    Regards.

    Simon B.


  • JF Staff

    Hi chaps,
    Would any of you be prepared to run a custom version of the app that will log some information for me that will help me track down where/why this is happening?
    Neither myself or any of my colleagues can reproduce this, which of course makes it a nightmare to try and diagnose and fix.



  • @Rich
    this
    Hi Rich,

    I have same problem - Airline and GA traffic compile in a few minutes with minimal use of PC resources. On starting Cargo compiling, CPU use shoots up to constant 20% and memory to constant 3.6GB. I have let it run for several hours without it reaching. This with an Intel 8 core over clocked processor!

    I have had this problem since early purchase of the product. I would be happy to run a custom version if it will help you.

    Charles



  • @Rich
    Hi Rich, I still have the same problem with v1.1.1.8 and P3Dv5. I publish a post last month in wich I show 3 sreen capture of the error message appearing just before compiling cargo flight. In that sreen capture, you can see the line of the programme where the error occur. Is it a revelant information or not ?



  • @Rich Hi Rich, In my previous post, I forgot to provide the link.
    It's here:
    https://community.justflight.com/topic/1116/stuck-on-creating-cargo-flight-plans-p3d-v5-hf2