v0.8.0 Altitude Hold Issue



  • Hello,

    After the upgrade to v0.8.0 I am having issues with the altitude hold mode in my beloved Arrow III.

    When I switch on the altitude hold mode the plane goes into a very steep climb... until stall. It is as if it remembers an altitude setting from earlier and is trying to climb back very aggressively.

    I have tried landing during flights and then switching on/off the AP and altitude hold mode to see if I can sort of 'reset' it. No luck.

    Anyone else having seen this?

    BR Søren



  • I had the exact same issue today, think I gave the ATC controller a panic!



  • @SuperKaro2014 exactly the same issue I have been experiencing after the upgrade. It seems it keeps a memory of the last VS setup (although there's no such VS option available, right)

    The AP roll issue is also ineffective, I have tried it once and the AP got crazy afterwards forcing a steep curve to the right making it impossible to use after all.



  • I find that it seems to behave much better when the autopilot is engaged. Altitude hold becomes disengaged when the autopilot is turned off. When it is subsequently re-engaged with the autopilot off it can react strangely. However this behavior does not appear to be consistent.



  • @anderson said in v0.8.0 Altitude Hold Issue:

    I have tried it once and the AP got crazy afterwards forcing a steep curve to the right

    Thanks for the feedback, I'll submit a ticket with support and reference this thread.



  • @SuperKaro2014 I've had a similar experience as well, I usually set the AP so it will follow my flight plans and allow the plane to climb to my desired altitude. It does go to about full climb, then slowly back down and then go back up until I click on the invisible location to have it hold.



  • @davidcrum I find Altitude Hold to work very well for me if engaged after first turning on the Autopilot. It appears to hold the altitude indicated when engaged even in a steep climb or descent as long as the autopilot is doing its thing. Altitude Hold becomes disengaged automatically when the Autopilot is turned off. I noticed that with the Warrior II Altitude Hold will not engage unless the Autopilot is functioning. Of course this is how it works when the Autopilot actually has an Altitude Hold function, and I am thinking that this may be the way JF has made an effort to improve its behavior. Be that as it may I also have experienced wild behavior when attempting to engage Altitude Hold when the Autopilot was turned off and at least for now I will simply avoid doing that.