Autopilot problems PA28 III\IV v3.0



  • I bought the PA28 III \ IV (v3.0) today, and I realized that the Autopilot does not follow the flight plan entered. The points are seen but does not follow them, while the AP with HDG and height works. Someone else has noticed or the problem is mine alone ...



  • @Ermy64 No you are not alone, the autopilot used to follow the GPS flight plan prior to the update on the 19th July to v0.3.0. I reverted to the previous version and autopilot function was restored. I have submitted a ticket to the helpdesk which is under investigation.



  • I have the same issue. Aircraft will not follow GPS nav points.



  • I just completed a 1 hour night flight from KCHA to KATL in the Turbo Arrow III using a GPS flight plan entered from the MSFS Flight Planning (World Map) screen. The autopilot accurately tracked the GPS course from takeoff to landing with no problem... I also planned a parallel VOR to VOR course, including an ILS landing at KATL, and I periodically switched the NAV/GPS switch (VLOC/GPS using the CDI button on th GNS 530) to make the autopilot follow either the GPS course or the VOR course. The autopilot was able to successfully intercept and track either the VOR course or the GPS course, depending on which one was selected. The autopilot was configured with the HDG switch ON at all times, and the Coupler dial set to either NAV or OMNI (both worked the same). The Coupler dial was then changed to LOC NORM for the ILS approach at KATL and it accurately followed the ILS localizer all the way to the runway threshold.

    The only anomoly I saw was that MSFS does not display the magenta GPS course lines very accurately. So, the plane is not always exactly on the line at all times, even though it is accurately following the GPS course as entered. This is much worse at places where the GPS course changes direction at a waypoint. MSFS rounds off the course line corners too much, so that it does not actually cross the waypoint.



  • MSFS does not display the magenta GPS course lines very accurately as it sometimes anticipates the trajectory as the plane cannot make sharp turns, however this does not mean that you are the only one who has so far had no problems with the new version, others of my virtual airline can no longer have the autopilot working perfectly, everyone agrees that the previous version had no problems.You are a lucky person 🙂



  • Press the heading button and then nav and the autopilot works well.



  • I just installed and tried a flight with v3.0 using the PMS50 GTN750 - for a short flight from EGHP RWY 26 to EGKA RWY20.

    Started off OK following the plan on the first leg, but then on reaching the next intermediate waypoint it turned off the plan northwards (about 25 degrees left) off course and kept going on that track. When I tried going to heading mode and turning it back towards the flight plan, it went haywire, diving steeply and I almost lost control.

    After that it would not engage AP without swinging wildly off course, so I brought it in manually all the way from there.

    This is behaviour I never saw with the previous update. Maybe not everyone will experience this but this is a big step down from the previous version, which has been rock solid for me. Perhaps I will try it with the default GNS530.

    Any help appreciated..

    Ray