Autopilot issue v8



  • I have not been able to use the auto pilot since updating to version 8.

    On the earlier versions, I would get my ILS frequency set up, ensure the GPS mode was enabled, the control knob below the left side Yoke was set to NAV (cannot remember the exact name of the knob).

    I would take off, reach my desired altitude, turn the AP on (using the "Z" key" and the plane would follow the waypoints to the destination airport.

    Now when I do that, the plane continues on the same heading. I have been able to use the heading bug and have it work that way, but now it seems it will not follow the flight plan that I made.



  • Think I have this solved. I was reading this forum and found out that the heading selector switch needed to be turned on. Once I did that I was able to follow the Magenta line without any problems.



  • @davidcrum I also was surprised to find it necessary to turn on the heading selector switch. I do not recall this being necessary in the previous version.



  • @sdvpilot said in Autopilot issue v8:

    @davidcrum I also was surprised to find it necessary to turn on the heading selector switch. I do not recall this being necessary in the previous version.

    To my knowledge it wasn't. However, it appears to be the case now, unless I am doing something really wrong (good possibility), lol



  • @sdvpilot it was not necessary and it makes no sense to have HDG on for GPS mode to work properly. Something is just not right in version 0.8.0 regarding the autopilot for there are other issues like Altitude Hold not working as well.



  • @anderson I'm fairly certain if the HDG switch is off, the autopilot just maintains "wings level" mode. Turning the HDG switch on engages the autopilot mode selected by the dial (e.g. nav, hdg, etc). So that behavior would be as expected



  • @vcapra1 said in Autopilot issue v8:

    @anderson I'm fairly certain if the HDG switch is off, the autopilot just maintains "wings level" mode. Turning the HDG switch on engages the autopilot mode selected by the dial (e.g. nav, hdg, etc). So that behavior would be as expected

    That is the behavior in this version, however, I have not touched that switch ever to turn the AP on 🙂



  • @vcapra1 I recall before v0.8.0 I had to remember to turn HDG off prior to engage NAV, for instance, in order to avoid problems with the AP. Now in v0.8.0 you are saying it is quite the opposite. It's a bit strange they had to change this procedure, but I will check on the manual for such instructions though - really don't remember have ever seeing it before.