Stalling behaviour: plane is stalling way too early



  • Hi,

    First of all, thank you JF for this great plane ! Love it so far.

    Also, I just wanted to point out some issues I am having with the plane in terms of stall behaviour. Basically, everytime I buy an add-on, the first thing I do is to stall it. Like you do in real life when fly a new plane for a check ride.
    Here I noticed that the piper is stalling way too early. According to POH it is supposed to stall at 60 knots at max weight in clean config.
    I tried to replicate this with no wind and ISA conditions. As you can see in the video I made (sorry for the quality), the plane starts to stall (not possible to climb more or maintain level flight) at 80 to 75 knots. Which is way to early.

    Again, this is not a complaint, just an observation if you want some feedback to improve the flight model. Also, let me know if it is a known problem or a setting that I didn't do. If there is a workaround, I would be happy to try it.

    Here is the video :

    https://youtu.be/O6z689Kchh0

    Best regards,

    Sanfelipe.



  • Perhaps you have the trim set for cruise speed and never changed it? If you are trimmed for level flight at 120 knots indicated airspeed, then there is a possibility that the trim tab is generating more nose down force than the model will allow you to override by pulling back on the yoke.

    Actually, I just replicated this in the turbo arrow. Try trimming nose up and see if that helps.

    This makes me wonder if the trim tab forces can override the yoke in the real plane. I'm likely flying tomorrow. If I do, I'll try trimming to cruise speed and then pull back power and see if I can stall the plane using only yoke inputs without having to trim nose up first. I've always trimmed when practicing stalls, so I really don't know what I'll find here. My guess is that I will be able to stall it but it will take a lot more force than would be comfortable. If so, the the trim tab forces might not be modeled correctly.



  • Hi Bernie,

    Thank you for your reply. I honestly don't know about the trim, didn't really pay attention while I was flying. I think I used it naturally meanwhile I was demonstrating my stall (like you do in real life as you mentioned) but I have to double check. I will try to replicate it this evening and see if it changes anything.

    Thanks!



  • Hi I just tried with different settings of trim, and it just make things worse.



  • I flew yesterday. With trim set for level flight at 3k and 120 knots I reduced power and pitched to maintain altitude. Somewhere around 65 or 70 knots the force required to keep level flight became very high. I was not comfortable continuing the exercise, so I can't say with certainty that if it is theoretically possible to out muscle the trim tab. I still think your problem is trim related. Double check what the trim is set to. Make sure the autopilot altitude hold mode is disabled. Failing that, I'd pursue it as a potential bug. As far as I know, its a unique problem you have encountered.



  • Hi Bernie,

    Thank you for your feedback. I actually flew again (in sim) and messed around more with the trim and it helped somehow, but what helped me more actually is playing with the weight. Flying with a lower weight helped me to reach the correct number, although normally, the stall speed in the manual is found with the maximum weight and c of g forward.
    Anyway, I still enjoy the plane. I am confident that new updates for the plane and the sim will only make the things getting better.

    Best.



  • This could be a Joystick calibration / sensitivity problem... Try recalibrating your Joystick using Windows/Control Panel/Game Controller Settings and then check the Controls/Sensitivity settings in MSFS. Also check the Customization/Elevator Authority setting on the Aircraft Selection screen for this aircraft.



  • @RetiredMan93231 Hi, I also tried that. I admit I have a 10 years old Logitech Extrem 3D joystick, not great, but not bad either. I used the advices on the forum for the settings (especially sensitivity) and increased a bit the dead zone since my Joystick has some noise due to its age. Again, it helped a bit, but hard to know if it is this or the weight/trim shift. I will try the the Customization/Elevator Authority setting on the Aircraft Selection, something I didnt think of.
    But other than that, I just love the plane !