Autopilot tried to kill me...



  • Hi, I just updated to version 0.2.0, I uninstalled previous version prior to install it. After takeoff (From MKJP) I activated the autopilot at 1000 ft and the plane just made a roll and went down.

    This has happened to someone else?



  • Yes. Same problem. PA-28R Turbo Arrow III after updating to 0.2.0. As soon as I turn on the AP the plane enters a steep bank and goes nose down. I was on NAV1, but same thing also happens when using the GPS. Happens with both HDG and NAV mode.



  • Same problem but not on every flight. Restarting the flight seems to fix this problem when it happens. This is not very helpful if the problem happens when turning on the autopilot well into the flight. The work around may be to check the autopilot early in the flight because once it does work without trying to kill you I think it may continue to work as needed throughout the flight. I will need more flight time to confirm this.


  • JF Staff

    Do you have state saving enabled?

    Is the aircraft in a turn when enabling the autopilot or wings level? What's your airspeed?



  • Same thing happened to me. I do a lot of long flights (randomly decided to travel around the world in my favorite plane) and I turned on AP to GPS mode just after takeoff only to have it do a 360 spin and slight dive towards the earth. I'm on the latest patch that released this morning. I was wings level when I activated. Same thing happens when turning on heading mode. Any activation of AP will cause a spin and dive. Didn't happen before the patch this morning but based on the posts here I don't think it's a problem with that update. I "solved" it by giving controls to my wife, i.e the MSFS built-in AI. I hope she doesn't cause more problems 😅



  • @Martyn
    I have experienced this problem after engaging the AP with wings straight and level climbing out after takeoff, and later on in other flights wings straight and level at a fixed altitude at cruise speed. After engaging the AP the aircraft would suddenly roll over and pitch down into a dive to the ground. If I was quick enough to turn off the AP and recover before crashing the problem would happen again later in the same flight after engaging the AP once more. However this did not happen on every flight, and it has not happened so far on the latest versions. When it did happen on the previous version I was able to use the AP safely after restarting the flight. FYI I have experienced other things randomly go haywire on any given flight like the gear status lights not illuminating after lowering the landing gear, or not being able to set the squawk code or a NAV frequency in the GTN750. Such problems would also usually vanish after restarting the flight.



  • I’ve finally found what causes this for me and can reproduce it

    This only occurs when I accidentally land the plane with the auto pilot on and shut down the plane and then do a cold start and take off with a new flight plan and turn on the auto pilot.

    It’s like it’s engaging parts of the old flight plan’s path or something!



  • @Stona This isn't the case for me. I hand fly every approach and landing so my autopilot is completely off from the approach phase on. I can confirm it doesn't happen every flight as I was successful in my latest leg, but I did have the same issue one time.



  • @Stona
    Same thing happened to me today. I’ll have to see if I can reproduce it. But it’s definitely a bug.

    Let’s hope it’ll get fixed in a future update.



  • same thing happened for me, a bit disappointing..
    I bought the addon last night.
    I fly the tutorial route. I'm at cruise altitude, VOR programmed to the right frequency, HSI is set up and in a straigth line I'm flying heading 95 or something.
    Switch on the autopilot, heading on, coupler set to Nav 1, coupler was by default set to HDG. Autopilot maintains the heading the heading bug is set to.
    When I switch the coupler knob to NAV, aircraft steep bank to the right
    and levels at opposite direction. As I'm writing this I realise what was wrong: the HSI needle was pointing in the opposite direction... make sure when you line up your HSI needle, the arrow is pointing upwards 🙂
    Screenshot 2021-06-21 225444.png

    thanks for being my rubber duck 🙂 ! awesome aircraft

    I hope this solves the issue for some?



  • @majorswitcher There have been no fewer than four times I've been typing up a question on this forum and before reaching the end of the post, figured out the issue that otherwise had be perplexed. So I can definitely relate to you there lol



  • @vcapra1 haha you're not the only one!!!



  • Ok some update. I was flying the Arrow IV yesterday and initially everything was fine. Suddenly the animations on the plane froze. The prop animation didn’t “spin” anymore and the strobes stopped flashing the plane continued to move over the ground normally though. No stuttering or anything else that looked like it was sim related. More like it was only related to the arrow IV. When the animations started again 10-20 seconds later the autopilot spun out of control. Hard bank and nose over.

    I then disengaged the autopilot and reset my heading and altitude. After re-engaging the autopilot everything was fine again.

    Does that help in finding the issue?