Turbo Arrow Three completely nonfunctional after install



  • I got the Turbo Arrow iii yesterday, and after a normal install I loaded up the flight sim to see the yoke fully deflected to the left, and it won't move when I move my joystick. The control surfaces move but the yoke doesn't. Also, non of the buttons, switches, or doors work, and when turning on the engine using ctrl-e, the engine stalls and turns off. The efb also is non-functional. I have been working to resolve this for a lot of time, but I have gotten nowhere. Please help me get this thing in the air!!!


  • JF Staff

    Does the warning 'Security Failure' appear on the EFB? If so, please contact our support team.



  • @Martyn Nothing shows up on the efb, and turning it on doesn't work.


  • JF Staff

    It sounds like the systems gauge isn't loading. There will be a waiting period the first time the aircraft is flown before that gauge is loaded, but that shouldn't be more than a minute or two.

    If you have left it running for a while with no change then please contact the support team, if you haven't already done so.



  • @Martyn Ok, I will try to see if it works.



  • @Martyn Waiting hasn't done anything



  • Im getting the exact same thing. Mine is installed to D drive and I suspect its due to the long filename issue.

    If I renamed the folder to a single letter then I get the EFB working with the Security Failure Message and the GPS loads, but the yoke is still fully deflected to the left and the instruments (horizon etc) are not working. I think some of the file names are still too long.


  • JF Staff

    @Travman said in Turbo Arrow Three completely nonfunctional after install:

    Im getting the exact same thing. Mine is installed to D drive and I suspect its due to the long filename issue.

    If I renamed the folder to a single letter then I get the EFB working with the Security Failure Message and the GPS loads, but the yoke is still fully deflected to the left and the instruments (horizon etc) are not working. I think some of the file names are still too long.

    Thanks for the information. Please also contact the support team if you haven't already done so.