How to map controls - Honeycomb Alfa + Bravo



  • I'm having trouble mapping the controls like battery, alternator, lights etc. on my newly acquired Honeycomb Alfa and Bravo in the JF PA-28R.
    I looks like the animated knobs and buttons in the cockpit don't react to the changes on the controller. For example I turn the battery on on my yoke and I can see the instruments come to life, but the knob doesn't change position in the virtual cockpit.
    Also the opposite is true (which is even worse). If I have the battery off on my yoke the switch in the cockpit has no effect.
    It's like their completely disconnected from each other and the physical controller has priority.

    Is this a matter of incorrect controller bindings or a bug in the model. I have tried mapping the switch, on/off and set commands. It doesn't make a difference. Tried both directly in the sim and using FSUIPC. Some things like gear and flaps work correctly. But lights, battery, alternator, pitot heat, fuel pump don't.
    I works perfectly fine in the default aircraft. It's only the JF PA-28R having this issue.

    Is there a specific way we should map the controls for it to work correctly? I so could someone please list the correct mappings?



  • Try changing the Honeycomb switch mappings to SET commands instead of the default ON/OFF commands. That's how mine is configured and it works fine... The SET commands will allow you to also control the switch with the mouse when the Honeycomb switch is in its OFF position. Assign the SET commands to the ON position of the Honeycomb switches. When you flip the switch on the Honeycomb you will see it "bounce" in the cockpit before moving to ON, this is normal and is just how the SET commands work.



  • @RetiredMan93231
    Thanks. I tried that already, but I will try again. What is the parameter to the set command? 0 or 1?
    Do you know if there a list which commands to use exactly for which switches in the JF Arrow III?

    The question remains why it works perfectly fine out of the box in default aircraft. Aren't they using exactly the same SDK? Why do I need special bindings and external tooling just for this aircraft.



  • There is no parameter required for the SET command... It will turn the cockpit switch ON (1) when you flip the toggle switch to the On position, or if you press and hold a button if you assigned it to one, and then it will automatically turn the switch back OFF (0) when you move the toggle switch to the Off position, or release the button.

    When you use SET commands for things like light switches they are not aircraft specific, and should work the same way with any aircraft. The command for the landing light switch is SET LANDING LIGHTS, which should be assigned to the On position of the toggle switch. The Off position of the toggle switch does not need a command assigned.

    This JF aircraft originally only supported the SET commands, but the latest release of the aircraft added support for the ON/OFF commands as well. So, if you are not using V0.4.0 you might not have the ON/OFF command support. But, it's still better to use the SET commands if you want to also control the cockpit switches with your mouse.



  • Oh OK. I thought I need something like "switch up" -> send SET 1, "switch down" -> send SET 0

    I suppose the naming is a bit confusing. I would expect a command called "SET" to have a parameter indicating the value to SET it to.

    So what you're saying is that the animation will follow only if you use the SET commands. Not on/off. The only downside of that is that initially they might be out of sync - what you seen in the cockpit and what you have on the H/W controller.

    I will test it out. Thanks.



  • @kowgli, The animation is resynced each time you flip the switch, that's why you will see the switch "bounce" when you flip it...



  • @kowgli I'm using the ON/OFF commands without any issue (other than them oddly not working for the beacon light). I prefer them only because they don't do the bounce when you turn them on, but as @RetiredMan93231 says they do prevent you changing switches with your mouse.

    As for why the switches bounce, I don't think it's because the animation is re-syncing. If that were the case it should only happen the first time, no? I thought it was because in the OFF position, the controller is sending nothing, but in the ON, it sends a SET command to turn it on. But like with any keyboard, when you hold down a key, there is a delay before it starts repeating, and during that delay the sim thinks you released the switch.



  • Doesn't work for me (neither SET or ON/OFF). I will try reinstalling (the plane), although I'm not sure how that will help.
    Everything works perfectly fine in default aircraft.



  • @kowgli , download it again to make sure you have the latest version...



  • I can get all the switches to work on the Alpha and Bravo controllers except I can’t get the fuel pump switch to work. I’ve tried SET as described above but no luck. On latest version 0.4.0. I’m interested in this thread to see if there is a way.
    Thanks
    John



  • @Johnwag Last I heard about it, that's a Simconnect limitation:
    https://community.justflight.com/topic/1938/on-off-control-assignments-issues/7
    Only the toggle control seems to work.



  • Ooh, ok, thanks