CTD when using GPS



  • Had two CTDs today, both around 1 hour into the flight, nothing special at the time of the CTDs.
    Using the 1.0.29 version of the GNS530 mod as well.
    It's hard to tell if it happens with other aircraft as well though since I'm not flying them.

    The changelog for 1.0.30 and 1.0.31 don't contain anything specific to CTDs, so I doubt that there were any fixes for that matter if it has anything to do with the mod at all...

    One more question to all using the mod: Did you have a flight plan loaded using the world map before that happened? Or did you enter it manually? Or did you use the stored flight plans feature of the mod?
    Also did your flightplan contain any custom user waypoints?
    Just trying to see if that might be related to the flight plan legs...



  • @theissondergaard Yes to both. Sorry, should have mentioned that.



  • @copper @KMan We can unite forces to see if we can figure something out 🙂

    Same problem as you, @copper : Not sure it's the Arrow's fault, but I really don't want to fly another aircraft for hours, just to figure this out 🙂 But I've had more CTDs in the past 3 days than I think I've had in total MSFS-lifetime, so definitely something wrong somewhere.

    I'm consistently using the JF Arrow, with state saving and the GNS530, with the mod. I fly VFR, my flightplans are made in the MSFS world-map with nothing fancy: Airport A to Airport B, either VOR-to-VOR or with a few airports added into the route to give me some waypoints. Short-ish flights, 2 hours max, most around 1 hour cruise.

    Yesterday, I had 2 ctd's while cruising. It was the exact same flightplan and crashed approximately at the same point, while cruising, some 30 minutes into the flight. Tried the same flightplan today, with no issue until I was far into an ILS approach when it made another ctd. After that ILS-crash, I "restarted" the flight mid-air close to my arrival airport, and completed the ILS approach with no issue..... go figure.

    Between these flights, I had another ctd during another flight, while transitioning from cruise to descent.

    I've just updated the GNS530 to 1.0.31. I've now successfully made a short flight without issues. I asked the gns530 developer on Discord, but he said there weren't any major changes from 29 to 31 that would/should either address or cause ctd's.

    Are you guys using the autopilot during flight, by the way?



  • @copper Just like you, I also have this feeling of "nothing special at the time of the ctd". It's not like I click a button and then it crashes, at least not to my recollection.



  • Okay, I'm not using state saving, so can rule that out for me. Did a Cold&Dark start in both cases.
    Started the flight without a flight plan and loaded it from the cockpit in the GNS530.
    Was using LittleNavMap as the only relevant application.
    Was using autopilot, but I doubt it's related.
    Real Time traffic enabled as well as plenty multiplayer aircraft around me today during a group flight (where it CTDed 2 times).

    I basically suspect it to be similar to the issues last autumn where some multiplayer/AI models caused CTDs when loading. It was solved by simply using the Generic Models for AI+Multiplayer aircraft.
    I currently have this option off (so I see proper models), maybe I'll try turning it on again.
    My community folder is empty except for the JF PA and two mods for it (which basically just change textures and a cfg file). So no addon aircraft models/liveries that could spawn for AI/multiplayer traffic.

    It's hard to reproduce since it happened 1hr into the flight, until then everything was smooth. Prior to this I was flying with exactly the same settings many flights without any issues.

    Maybe people reading this see some pattern in the setup 🙂
    I think it's rather a MSFS issue than something related to the mod or the model. Basically none of them should be capable of forcing a CTD anyway.
    It's just that in a forum like this you'll probably find many people flying the JF PA with the GNS530 mod 😉



  • @copper great info, and some "good" differences to my setup. It makes me also think that it's MSFS rather than anything else.

    • I also start cold and dark (but with state saving, picking up from last flight)
    • Loads of stuff in my community folder, but only proper mod is the gns530, the rest are airports, landmarks, liveries etc
    • I only recently started using the AP, which is why I asked. Still somewhat of a suspect to me 🙂
    • Real-time traffic on, as always

    I'll try another long-ish flight tonight with current setup, see if there's a crash. If there is, I'll try the Generic Models thing. What exactly is the setting in MSFS?



  • @theissondergaard I think the setting is in the General -> Traffic menu. Before it was in the General -> Graphics.
    It's called "Use generic aircraft models for AI" and "Use generic aircraft models for Multiplayer" I think. Setting it to ON will use the "easier" models which costs less performance and last year was a solution to CTDs.
    It's just something worth trying since the impact of it being set to "ON" is marginal.



  • @copper I'll try it - but first I'll keep my current configuration and see if there are crashes. I did update the gns530 mod to 1.0.31, so maybe, just maybe 🙂 I'd recommend you to do the same.



  • Just did a flight with AI traffic completely disabled and had no crash.
    Nothing else changed (well, the area I was in). It was again a group flight with many members, all went fine.

    I'll leave the AI traffic disabled to see if that might be a reason. If no more CTDs happen, I'll try to enable it again but with generic models.

    Will now also update to 1.0.31 of the GNS530 mod, but just because I want those new features 🙂



  • @copper I’m also use the GNS mod, AI traffic always off, no MSFS flight plan loaded and I’m experiencing CTDs.

    My guess is either State Saving, or GNS mod itself.

    I don’t think it is the AP neither, because I even had a CTD grounded, at ramp, while loading waypoints in gps interface before engine start...



  • @fjadiego Great info, thanks. Interesting with the AI traffic off. How about your Community folder in general - anything in there?

    I'm definitely suspecting something memory related, given the lack of consistent timing, and as it has happened as I've approached airports.



  • @theissondergaard I have the usual stuff, FBW Airbus, DA62 mod, and other standard planes mods.

    I just tested after my previous post and flew the same route I’been trying to finish for 4 times now: AI off, Panel State saving off, AP on with NAV on, GNS530 mod on and FPL manually loaded, no scenery add-ons, no MSFS route, still CTD.

    I’m trying to fly from LSZC to LEGE over Geneva and Montpellier. I got two CTDs 20NM around Montpellier, one on ramp at LSZC while messing with the GPS, and the last one climbing to 9,000 5 minutes after flying over Geneva.

    I’m starting to think that it can only be the GNS mod itself... AP was off in one of the crashes, Panel State saving in another.

    Last try is going to be loading the flight with Panel State Saving off from the beginning, because in the previous CTD, Panel State Saving was on at the beginning, I turned it off, and set Cold and Dark status.

    I’ll come back with news on this last experiment.



  • @fjadiego Looking forward to it. What version of the mod are you using?

    I've updated to v1.0.31. The only other change I've made today is to change my Windows pagefile to fit my physical memory size, following the advise in this one:
    https://flightsimulator.zendesk.com/hc/en-us/articles/360015893879-Crashing-CTDs-issues
    (I updated my computer from 32 to 64GB ram about a month ago, so figured there might be something there)

    Only had one flight today, following normal procedures and didn't try to "be careful" in any way. Had no issues. Massive amounts of stutter around 30 minutes in, and was sure it was going to crash. But it didn't, framerate came back after maybe 20 seconds and then smooth flying all the way to parking. Will try to get another flight in today, to/from more busy airports and see what happens.



  • @theissondergaard No luck 😞 CTD after Geneva.

    I noticed the same stuters you mentioned and 3 minutes after going away, I was looking at my desktop...

    My GNS530 version is .31, or 32, the last one, downloaded yesterday.

    I’ll try your fix and see if I can get to Spain this time...



  • @fjadiego Sorry to hear that! 😞

    Status from my side: Very good. 3 flights today, with no crashes (to the desktop, at least 😃 ).

    I haven't changed anything, apart from updating the 530-mod to 1.0.31 (I see there's a .32 now), and the thing with the Windows pagefile. I used the airplane "fully" in all three flights, including heading mode on AP when cruising, ILS approaches to fairly large airports, numerous COM and NAV changes, even an on-ground flight plan change for a second leg.

    At this stage I don't really have anything that suggests that the Arrow is/was causing the crashes I experienced. More likely, I think I was/am experiencing some memory issues, possibly related to items in my community folder being loaded randomly at close-by airports - perhaps some faulty liveries causing issues at random, perhaps some memory-leaks, depending on whether the sim spawns them or not.

    If I were you, I'd definitely try a few flights with an empty community folder, including liveries and all. If I do have another CTD, that's next on my list to try, anyway, unless anyone have suggestions 🙂

    But right now, all good. 👨✈



  • I've logged about 10 hours in Arrow since uninstalling the GNS530 mod. No CTDs since then. My setup (with and without the mod):

    • Live weather, live traffic, flight plans loaded using the MSFS world map, VFR and IFR.
    • Using both default GNS530 or JF G100. No state saving.
    • Starting cold and dark.
    • I fly in VR.
    • Other active mods are: Navigraph, Global AI Ship Traffic MSFS V1 (recommended!), eBag (recommended!).
    • Other active apps while running the sim: FSUIPC.
    • PC: Ryzen 3600, 16 GB RAM w/ 12 GB max page file (managed automatically), GPU 3080, SSD.

    I also had no CTDs before using the GNS530 mod.

    I can confirm that nothing obvious or special happened when the CTDs occured. No stutters or lag, no heavy scenery, or lot of ATC chatter, anything like that. It was kinda out of the blue.

    Of course, it may or may not be related, but in my case, the mod is unfortunately high on the list of suspects.



  • @Ohmsquare Great info!

    On the one hand, I do also suspect the 530-mod. On the other, I used the 1.0.29 version for a long time (a month or more?) without issues, and then I started getting frequent CTDs shortly after upgrading JF Piper from .2 to .3 - which was why my first suspicion was the airplane.

    Thanks to this thread in the forum, I now know a lot more - but even more confused 😃



  • I have never had MFS crash before except when the Carenado Mooney was broken. But recently, when approacing the first VOR of the Arrow III tutorial flight, MFS crashed out of nowhere. I was using the GNS530 in the Arrow III at the time. I use no other mods than the GNS530 (up-to-date), and since deleting the mod it has not occured again ever since. I will stay off that mod for now just to be safe.



  • I now did several flights of 1-2 hours and no CTDs.
    The only things change since the last CTDs is to disable all AI traffic and to update graphics drivers to the most recent 465.89 (Nvidia).
    The GNS530 mod is installed and up to date (1.0.32).

    So I still highly suspect the AI traffic (realtime or offline) and it's models causing it. Since we had this issue in autumn and it behaved very much the same way.
    It also explains CTDs when approaching major airports since there MSFS spawns ground aircraft and loads their models.



  • Definitely tend to agree with @copper. I got a response from the developer of the gns530 mod, who said that there's nothing in v30+ versus v29 that would make a difference in terms of crashes. Here's his full response:

    Difficult to answer here. I got CTDs myself with or without the GNS530 MOD. A CTD is always a kernel crash and not a MOD issue written in javascript. We hope Asobo to make the kernel not crashing in any way as far it is possible. Now , the kernel may crash following some orders sent by a MOD (that places the kernel in crash condition).
    Sometimes you may have also a temporary freeze especially when selecting a waypoint. This comes back after seconds. Again here, this is at kernel level. I can't do anything.
    If the CTD occurs while you don't do anything with the GNS530 buttons, this will be difficult to analyse and it may be caused by many internal events, even with something not related to the MOD. Try to disable traffic here since it may cause hazardous conditions.
    Any CTD sequence that can be reproduced will help. Don't hesitate to send them to me (but well checked and not a 3hours flight!). Be sure also to read the bug reporting section of the documentation.
    Nothing changed here since 1.0.29. The only difference between 1.0.29 and last version 1.0.31 concerns some minor things and the OBS implementation. Nothing that can cause a CTD here.