CTD when using GPS



  • That is twice now that this happened.
    It only happens when using GPS.
    No problems with any other navigation systems.
    Anybody else has this issue?


  • JF Staff

    Are you referring to the GPS 100 unit?

    Does it occur at a predictable point, e.g. selecting a specific menu page, scrolling through the nearest waypoints?



  • Iโ€™ve had 2 ctd today flying the arrow, out of two attempted flights. Different routes and locations, but both happened perhaps 30 minutes into the flight. Way to early for me to say what was to blame - it doesnt have to be the arrow, it could be msfs, my gns530 mod, a lot of other things.... But ctds have been rare for me in general, so two in a row makes me suspicious. Iโ€™ll try a few things tomorrow to identify whether itโ€™s the arrow or not, will let you know.



  • @theissondergaard I had my first CTD today on final approach after a 2 hour flight. Out of no where, on a nice glide path, suddenly dark.



  • @KMan Are you using the GNS530 in the Arrow? And also, are you using the popular GNS530 mod? I'm "yes" on both those, so today I'll see if I can find some pattern.



  • @Martyn I imagine that CTDs must be super hard for you to nail down - and especially whether it actually is your code or someone else's. Is these anything we could do, that would enable you to figure out whether these are caused by the Piper or not? It's not like MSFS has never crashed to the desktop before.... ๐Ÿ™‚ Are there crash-logs somewhere that would be useful?



  • Not backed up by any hard evidence, but I experienced CTDs after installing the GNS530 mod (v1.0.29*). Removing it apparently solved the issue.

    *EDIT: There has been several updates to the GNS530 mod since then. I haven't tried those yet.



  • @Ohmsquare yeah, definitely hard to be sure what causes what ๐Ÿ™‚ There is indeed a new version 0.30, released yesterday, which I haven't installed yet. Right now, though, I'm in the middle of exactly the same flight that cause a CTD yesterday, with no issues so far - with exactly the same plane and configuration. So again, very hard to figure out what caused it...



  • Had two CTDs today, both around 1 hour into the flight, nothing special at the time of the CTDs.
    Using the 1.0.29 version of the GNS530 mod as well.
    It's hard to tell if it happens with other aircraft as well though since I'm not flying them.

    The changelog for 1.0.30 and 1.0.31 don't contain anything specific to CTDs, so I doubt that there were any fixes for that matter if it has anything to do with the mod at all...

    One more question to all using the mod: Did you have a flight plan loaded using the world map before that happened? Or did you enter it manually? Or did you use the stored flight plans feature of the mod?
    Also did your flightplan contain any custom user waypoints?
    Just trying to see if that might be related to the flight plan legs...



  • @theissondergaard Yes to both. Sorry, should have mentioned that.



  • @copper @KMan We can unite forces to see if we can figure something out ๐Ÿ™‚

    Same problem as you, @copper : Not sure it's the Arrow's fault, but I really don't want to fly another aircraft for hours, just to figure this out ๐Ÿ™‚ But I've had more CTDs in the past 3 days than I think I've had in total MSFS-lifetime, so definitely something wrong somewhere.

    I'm consistently using the JF Arrow, with state saving and the GNS530, with the mod. I fly VFR, my flightplans are made in the MSFS world-map with nothing fancy: Airport A to Airport B, either VOR-to-VOR or with a few airports added into the route to give me some waypoints. Short-ish flights, 2 hours max, most around 1 hour cruise.

    Yesterday, I had 2 ctd's while cruising. It was the exact same flightplan and crashed approximately at the same point, while cruising, some 30 minutes into the flight. Tried the same flightplan today, with no issue until I was far into an ILS approach when it made another ctd. After that ILS-crash, I "restarted" the flight mid-air close to my arrival airport, and completed the ILS approach with no issue..... go figure.

    Between these flights, I had another ctd during another flight, while transitioning from cruise to descent.

    I've just updated the GNS530 to 1.0.31. I've now successfully made a short flight without issues. I asked the gns530 developer on Discord, but he said there weren't any major changes from 29 to 31 that would/should either address or cause ctd's.

    Are you guys using the autopilot during flight, by the way?



  • @copper Just like you, I also have this feeling of "nothing special at the time of the ctd". It's not like I click a button and then it crashes, at least not to my recollection.



  • Okay, I'm not using state saving, so can rule that out for me. Did a Cold&Dark start in both cases.
    Started the flight without a flight plan and loaded it from the cockpit in the GNS530.
    Was using LittleNavMap as the only relevant application.
    Was using autopilot, but I doubt it's related.
    Real Time traffic enabled as well as plenty multiplayer aircraft around me today during a group flight (where it CTDed 2 times).

    I basically suspect it to be similar to the issues last autumn where some multiplayer/AI models caused CTDs when loading. It was solved by simply using the Generic Models for AI+Multiplayer aircraft.
    I currently have this option off (so I see proper models), maybe I'll try turning it on again.
    My community folder is empty except for the JF PA and two mods for it (which basically just change textures and a cfg file). So no addon aircraft models/liveries that could spawn for AI/multiplayer traffic.

    It's hard to reproduce since it happened 1hr into the flight, until then everything was smooth. Prior to this I was flying with exactly the same settings many flights without any issues.

    Maybe people reading this see some pattern in the setup ๐Ÿ™‚
    I think it's rather a MSFS issue than something related to the mod or the model. Basically none of them should be capable of forcing a CTD anyway.
    It's just that in a forum like this you'll probably find many people flying the JF PA with the GNS530 mod ๐Ÿ˜‰



  • @copper great info, and some "good" differences to my setup. It makes me also think that it's MSFS rather than anything else.

    • I also start cold and dark (but with state saving, picking up from last flight)
    • Loads of stuff in my community folder, but only proper mod is the gns530, the rest are airports, landmarks, liveries etc
    • I only recently started using the AP, which is why I asked. Still somewhat of a suspect to me ๐Ÿ™‚
    • Real-time traffic on, as always

    I'll try another long-ish flight tonight with current setup, see if there's a crash. If there is, I'll try the Generic Models thing. What exactly is the setting in MSFS?



  • @theissondergaard I think the setting is in the General -> Traffic menu. Before it was in the General -> Graphics.
    It's called "Use generic aircraft models for AI" and "Use generic aircraft models for Multiplayer" I think. Setting it to ON will use the "easier" models which costs less performance and last year was a solution to CTDs.
    It's just something worth trying since the impact of it being set to "ON" is marginal.



  • @copper I'll try it - but first I'll keep my current configuration and see if there are crashes. I did update the gns530 mod to 1.0.31, so maybe, just maybe ๐Ÿ™‚ I'd recommend you to do the same.



  • Just did a flight with AI traffic completely disabled and had no crash.
    Nothing else changed (well, the area I was in). It was again a group flight with many members, all went fine.

    I'll leave the AI traffic disabled to see if that might be a reason. If no more CTDs happen, I'll try to enable it again but with generic models.

    Will now also update to 1.0.31 of the GNS530 mod, but just because I want those new features ๐Ÿ™‚



  • @copper Iโ€™m also use the GNS mod, AI traffic always off, no MSFS flight plan loaded and Iโ€™m experiencing CTDs.

    My guess is either State Saving, or GNS mod itself.

    I donโ€™t think it is the AP neither, because I even had a CTD grounded, at ramp, while loading waypoints in gps interface before engine start...



  • @fjadiego Great info, thanks. Interesting with the AI traffic off. How about your Community folder in general - anything in there?

    I'm definitely suspecting something memory related, given the lack of consistent timing, and as it has happened as I've approached airports.



  • @theissondergaard I have the usual stuff, FBW Airbus, DA62 mod, and other standard planes mods.

    I just tested after my previous post and flew the same route Iโ€™been trying to finish for 4 times now: AI off, Panel State saving off, AP on with NAV on, GNS530 mod on and FPL manually loaded, no scenery add-ons, no MSFS route, still CTD.

    Iโ€™m trying to fly from LSZC to LEGE over Geneva and Montpellier. I got two CTDs 20NM around Montpellier, one on ramp at LSZC while messing with the GPS, and the last one climbing to 9,000 5 minutes after flying over Geneva.

    Iโ€™m starting to think that it can only be the GNS mod itself... AP was off in one of the crashes, Panel State saving in another.

    Last try is going to be loading the flight with Panel State Saving off from the beginning, because in the previous CTD, Panel State Saving was on at the beginning, I turned it off, and set Cold and Dark status.

    Iโ€™ll come back with news on this last experiment.