Propeller not stopping on shutdown



  • I just did a flight from Popham to Alderney in inclement weather, descending from 8,000ft to 1,500ft due to icing.

    After taxiing to parking and doing a normal shutdown correctly as per the checklist, with everything off the prop kept on spinning and didn't stop (although the engine sound did stop correctly). The battery, mags and all other switches were off, the engine RPM gauge was showing zero and the manifold pressure gauge was correctly showing atmospheric pressure. The throttle was at idle, mixture at idle cut-off and fuel was also off. The aircraft "oscillated" periodically for a few seconds as if the engine was shutting down. Between each period of this oscillating the aircraft was steady with the prop still spinning (don't know what speed but the blades were a blur). This oscillating happened at intervals from about 10 seconds to several minutes (no apparent consistency) but the prop kept on spinning all the time. After about 10 minutes of this the aircraft started oscillating continuously and just kept doing so with the prop continuing to spin. I left it going and after about 15 minutes of this the prop occasionally slowed so that I could see the individual blades then sped up to a blur again. This slowing and speeding up again only happened 3 or 4 times. Eventually I exited with the prop still spinning.

    This is with v0.2.0 and I've only seen this the one time in more than 50 flights. (Ticket submitted.)

    As an aside (and I don't know if it's related to the prop issue or not) on downwind at Alderney the gear failed to come down - no green lights and the Auto Extension Off light wasn't lit either. Checked the circuit breakers and yes the one for the landing gear had popped out. Pushed it back in and problem solved. I didn't realise that this particular failure was actually modelled - pretty cool I thought!! 🙂

    EDIT: Before installing v0.3.0 I uninstalled v0.2.0 using the Just Flight uninstall shortcut in the start menu.



  • Confirmed being caused by wind. See this thread:
    @Sender46 said in v0.3.0 issues:



  • Same here. The propeller keeps spinning after everything has shut down and the wings wobble back and forth like a monkey is jumping up and down. Apart from that, everything else is hunky-dory!