Update 0.2.0



  • I am wondering if update 0.2.0 has been released. I have not had any notification. Should I have received an email as I’m not sure how the process works now?

    I guess what I’m really wondering is how do we know what is the current release, is it only by receiving an email. Looking in “my account, your orders” shows the download link but not what version it is



  • Yes, just download it again from your orders page in your JF account. Once downloaded it will be labeled as "Install_Arrow_MSFS_0.2.0.exe" Install it and it will update your older version.

    Sadly, this new update hasn't resolved my issue with the battery being constantly flat with no ability to recharge it to full. Unable to do a cold start etc. Also all outside lights, beacon etc are not functioning either for me because, well, the battery is flat! Caught in a vicious circle. LOL.



  • Thanks for your reply, I'll download now and give it a try



  • I see that the .exe has the version number when you press the download button, so that is OK



  • It was a great plane, now after update v0.2.0 it is a real joy to fly. Top marks to the team. It’s a real Thoroughbred, Thank you.



  • I look forward to the Turbo release next. The performance increase suites my need for speed.



  • @Frank-G yep sadly my celebrations were a bit premature, it did work for me and I had voltage , but today it is back to square one, flat as a pancake, no cold start. 😞



  • @Shado2k Oh dear, I hope they can sort out the random dead battery issue. I did think it was possibly something else in the community folder that caused the conflict issue so removed everything and only left the Just Flight Piper Arrow folder in there - but still no improvement.



  • @Frank-G It is quirky and I dont fully understand how everything ties together nowadays with the new systems/sims, they are similar goings on with the new CRJ by Aerosoft, whether its the sim or one of its components like sim connect I do not know but Im sure the team working together with Asobo will sort it, just frustrating.



  • @Frank-G I had the problem with flat battery after a few minutes.
    I unchecked the "enabled" tick-box below the oil refill and recharge battery options and disabled "state saving" and all went back to normal for me.



  • @Frank-G do you happen to have a Simconnect.cfg file lurking around in your documents, or maybe you have installed kinetic assistant at some point? (recommended for Glider installs) if the answer is yes remove them or move them and give the Arrow another try, humour me please 😉



  • @Shado2k Yes, to both. I removed Simconnect.cfg and Kinetic Assistant and I confirm that action SOLVED the problem with the dead battery. I now have a working Piper aircraft. All lights are working. Battery at 12 volts and I can do a cold start. Thank you so much! You solved the problem. Your solution needs to be pinned up somewhere! Many thanks! 😁



  • @Frank-G Aha that's great news 👍 at last you can enjoy it to its full potential, its no problem, happy to help👍


  • JF Staff

    Thanks for the assistance Shado2k. I've notified our support team in case it helps others too.