Battery and/or oil will not recharge, plane unflyable



  • Hey all, I've already requested a refund for the addon given the 5 days I've spent troubleshooting it to no avail, but I wanted to start a thread here for others having this specific issue as I know I'm not alone. There's already some conversation about it in another thread about security issues.

    I have MSFS Steam on Windows 10 Pro 64 Bit, my sim resides on G:\Microsoft Flight Simulator
    I have tested it both with and without my Honeycomb Alpha plugged in, as well as before and after removing the Logitech pro flight panel driver (I have not used that switch panel, but the driver was still installed so I removed it just in case it was interfering.)

    The issue at hand is: After my first flight 5 days ago, I loaded the sim and the aircraft showed 0 battery. The recharge button does nothing. I did a repair install, it didn't work. Did a full uninstall, removed all of my other addons and reinstalled, same problem immediately. I found that several files are installed to C:\Users[username]\AppData\Roaming\Microsoft Flight Simulator\Packages\justflight-aircraft-pa28-arrow-iii\work, including userinfo.txt, JF-PA28_ArrowIII.ini and a PanelSave folder with a StateSave.ini file. I attempted to edit JF_PA28 _ArrowIII.ini to change the oil and batt, which at the time of writing read 0.000000 each, but upon loading the aircraft seems to do some kind of file checking as it quickly reverts.

    At present, that file looks like this:

    OIL=0.000000
    BATT=0.000000
    CHECK=1.230000
    WRITE_TEST=0.000000
    [OPTIONS]
    GPS=2
    DISABLE_SOUNDS=1
    DISABLE_FAILURES=0
    DISABLE_STATESAVE=1
    DISABLE_PANELSEL=0
    DISABLE_CFGSAVE=0
    AUTOFUEL=0
    HSI=1
    [DEBUG]
    READ_TEST=123
    

    I then tried another full uninstall, deleted these files, then did a clean install again. Same issue. The aircraft now can't be started at all using any method I've tried (CTRL+E, the EFB, manually using the clickable switches, etc.) This level of "realism" is nice in theory but it has caused my $45 and 5 days of troubleshooting to be for nothing.

    I'm hopeful that either Just Flight or the community will figure this out soon. I look forward to trying the addon again down the road when it can support the Honeycomb Alpha and is free of these bugs.



  • There will be an update today or on thursday, hopefully the "refill oil" and "recharge battery" buttons will be fixed despite them not being mentioned in the changelog.

    While I did not have the same critical impact as you have (the battery recharge button simply always sets the battery to a low 8.8 volts), but I think as long as maintenance is not enabled, oil and battery should simply be ignored for the sake of simplicity.

    Since it's otherwise a really nice addon, I hope the issue gets fixed for you so you can enjoy it as well...



  • @copper Unfortunately things got worse after the update somehow. Working with Craig, but now the battery recharges to 8.8v then dies at 8.0v. The oil claims to have 8qt, but the engine will not start under any circumstances or using any method. The aircraft is fully bricked for me now.


  • JF Staff

    The battery only recharging to 8.8v is unfortunately a bug with the SimConnect functionality of MSFS itself and we're waiting for Asobo to address that.

    The other issues mentioned above would need to be investigated by support due to the PC specific nature of the write issue.



  • @Martyn Thanks Marytn - I have a ticket open with Craig now, hopefully we can make some progress.



  • @Martyn said in Battery and/or oil will not recharge, plane unflyable:

    The battery only recharging to 8.8v is unfortunately a bug

    Wouldn't that be something for the FAQ or release notes of the update?
    I mean, it's a known issue, basically breaking the functionality of enabled Maintenance and State Saving and you let every customer run into the issue, waste time to look for a solution on their end, while all is known and you're waiting for Asobo.

    Please be transparent about known issues. There is no benefit of letting people writing in forums, opening support tickets etc. about that.
    Thanks



  • Following a tip from Frank G on Facebook, I got rid of the simconnect.cfg file in Documents which is put there by Little Navmap. This seems to have fixed the battery issue for now, however the oil is still not refilling and is stuck at 0. Frank also suggested fully removing Kinetic Assistant, but this didn't fix the oil situation. Very curious bug, but I can only assume at this point the oil is being interfered with by some other addon's simconnect file. I'll keep hunting.



  • @LostPilot Welp, no luck finding anything else. The G91 by SSW does have its own simconnect DLL files so I disabled that addon, but no change on the Arrow. Any other addons that use it don't seem to be running or store their config files anywhere standard, so not sure what's up with the oil yet. After a day of not getting it to start, it magically saw oil again (yesterday) and then as of this morning, it's back to 0 oil with no way to refill. It's very temperamental.