V1.1.2.0 is broken



  • I received the email about the release of 1.1.2.0. After downloading the file I uninstalled 1.1.1.9. Installed 1.1.2.0 and everything seemed to go OK except that is said it was version 1.1.1.9 and not 1.1.2.0.

    I ran the compiler and it locked up the program. Had to end task and try again. Same issue. Locks up when generating GA flight plans. Tried uninstalling and then reinstalling 1.1.2.0.

    Now the setup wizard will not run. It shows my P3D v4.5 and v5 locations but when I start the wizard it gives an error that it can't fine users...\documents\trafficglobal\compiler\traffic_global_airliners.bgl
    I checked for that file and it is not there.
    If I hit continue then I get
    traffic global scenery library entry already present
    and everything stops. I tried running the compiler again but it stops when generating GA flight plans. I let it run for 15 minutes before having to end task on traffic global.
    So I have removed 1.1.2.0 and installed 1.1.1.9 and that runs ok.



  • After I reinstalled 1.1.1.9 I checked my documents\TrafficGlobal\compiler for the Traffic_Global_Airlines.bgl file and it was there. So apparently 1.1.2.0 isn't installing that file.



  • Same here, the new installer ends in a error.

    Cheers, Pete



  • While I was running the compiler on 1.1.1.9 it was taking a very long time. I checked in the GA aircraft folder and saw the schedule.dat file size was increasing. So I let it continue and it finished. Perhaps that was the issue with 1.1.2.0. But it wouldn't work correctly without the Traffic_Global_Airlines.bgl file.



  • yes, i have the same error!
    We need the version 1.1.2.1 😉



  • I will add my name to this list of problem with the new version 1.1.2.0. I get the MS .NET Framework Unhandled exception and could not find file users...\documents\trafficglobal\compiler\traffic_global_airliners.bgl. I also have the version showing on bottom left as V1.1.1.9. I guess I will uninstall this one and go back to my previous download.



  • My install seems to run OK - BUT it still says v1.1.19 when it finishes.

    So is this 1.1.19 or actually 1.1.2.0 that hasn't updated the version number?


  • JF Staff

    @Rog

    Looking into it now. Someone has reported an issue via JF Support.



  • Definitely Broken... I have gone back to the previous version



  • I got it installed but when it finished compiling, i get the message unable to copy data (or something like that). I ran it as administrator too, so I don't know what's going on. I submitted a ticket to JustFlight so let's see what's going on.



  • Not installed it yet to much on for the next few days.


  • JF Staff

    v1.1.2.0 should now be fixed and is back up on the server, sorry for the inconvenience.



  • Still version 1.1.1.9 after downloading😒



  • @Voice-of-Reason
    Also still version 1.1.1.9. The traffic files don't get installed in the P3D map and the airport inspector throws an illegal value error on parameter Lattitude when an airport is selected.

    Nice testing work!!!



  • Downloaded v1.1.2.0 from my account @ 13:00 GMT so I've hopefully got the corrected program. (even though it's still showing as v1.1.1.9).
    Uninstalled v1.1.1.9 and installed v1.1.2.0 which installed these files into FSX-SE scenery/world/scenery:-

    TrafficGlobal_AI.bgl [14.1 Mb]
    TrafficGlobalCargo.bgl [2.55Mb]
    TrafficGlobalGA.bgl [6.35Mb]

    Now, I've just spent the last hour or so compiling with just about any combination that I can think of and the result is always the same.
    TG v1.1.2.0 compile.jpg

    The compiler completes in each case, save for GA which seems to hang (takes >10 mins and process goes unresponsive) but, although the timestamps on the bgls alter, the actual sizes remain exactly the same as the default ones shown above.

    In all previous versions, the filessizes have changed (obviously) to take into account installed airport sceneries/afcads (well, that is aside from Cargo flights which I had yet to get to compile since v1.1.1.6).

    All very strange, unless I'm doing something monumentally stupid......😁



  • @Capt-Quirk Did your remove the bgl files before installing the latest version? On my PC the bgl files were not removed during uninstall. So, in that case the bgl files are from the old version.
    When I copy the compiled bgl files from the compiler map in de documents/TrafficGlobal map manually I see the changes.



  • @snoopy_belgium
    Thanks for the suggestion but, no that doesn't appear to be the problem as uninstalling TG has always removed them all automatically.
    Traffic_Global_Airlines.bgl (v1.1.1.9) is now TrafficGlobal_AI.bgl (v1.1.2.0) so, if this had have been the case I would still have both files
    I've had every version since the very first release in May 2018 but never had this particualr issue before (which still doesn't mean that I haven't overlooked something, of course).
    EDIT: perhaps you were right though! I just uninstalled v1.1.2.0 & it did leave the files behind! (going to try redownloading and reinstalling...sigh)



  • The error on installation of 1.1.2.0 is already fixed?
    I have the error when it runs the wizard the script gave me an error of a missing bgl file on docs/trafficglobal/compiler/...



  • @Voice-of-Reason said in V1.1.2.0 is broken:

    v1.1.2.0 should now be fixed and is back up on the server, sorry for the inconvenience.

    Apparently.....



  • I'm definitely getting too old for this....
    Uninstalled v1.1.2.0 ( & deleted the traffic bgls)
    Re-downloaded @ 15:00GMT and installed
    Ran compiler
    Exactly the same results
    Compiler for GA still chugging away @ > 20 mins
    I give up (well worth the £7 I saved by buying the EA version and fiddling about for the past 2 and a half years!)!