BAe 146 Professional - vhf COM radio's seem unactive flying on Vatsim



  • I noticed the following: when flying on Vatsim it's impossible to listen/talk through the COM1 and COM2 radio's. They are active, have power, and are set to the right frequencies.
    I never had this before with any plane.



  • I don't use Vatsim, but I have run into the same issue with Pro-ATC X too - starting cold and dark in P3D v4.5 I run through the checklist including switching on the avionics master A and B on the overheard, but I can't get any external comms on battery, ground power, APU or with the engines running (it does, however work with the default ATC). I have found a temporary workaround - try assigning a key combo to the avionics master switch, and turn it on this way. It not ideal and even using this method mine keeps cutting out every 10 minutes or so...give it a try and see how you get on.


  • JF Staff

    I've replied to a similar report on another thread:

    I'm not a VATSIM user but our code is triggering the default audio selector events based on the audio panel control selections - COM1_TRANSMIT and COM2_TRANSMIT.

    If it's working correctly with the default ATC then that'd suggest that it's working as intended so I'll need more information on what VATSIM is checking to ensure compatibility.

    The FS avionics master is being set to on when there the AC emergency or DC essential bus is powered and the two avionics master switches on the overhead are set to ON.

    I have however just spotted a bug in the code though which will be fixed in the next update, so thanks for pointing this out!



  • @Martyn said in BAe 146 Professional - vhf COM radio's seem unactive flying on Vatsim:

    I've replied to a similar report on another thread:

    I'm not a VATSIM user but our code is triggering the default audio selector events based on the audio panel control selections - COM1_TRANSMIT and COM2_TRANSMIT.

    If it's working correctly with the default ATC then that'd suggest that it's working as intended so I'll need more information on what VATSIM is checking to ensure compatibility.

    The FS avionics master is being set to on when there the AC emergency or DC essential bus is powered and the two avionics master switches on the overhead are set to ON.

    I have however just spotted a bug in the code though which will be fixed in the next update, so thanks for pointing this out!

    The audio works until the avionics master switches are set to 'ON', is that the bug you have already spotted?


  • JF Staff

    Yes, the logic is currently reversed and that has now been fixed. Update coming very soon.



  • I also have this issue but on another network PilotEdge. The 102 released seemed to have fixed it, I tried a flight from Las Vegas to Boise, however, issues arose around 50 miles north of BTY.

    I changed frequencies and checked in with the new controller, they heard the check-in and responded, I then tried to reply and got no response. I was disconnected from the network as it was causing issues, ie the controller could hear me but I couldn't hear them. I tried reconnecting a second time but with the same issue, I couldn't hear the controller response.

    It was as if the volume on the com radio had been reset to zero, I checked this at the time and it hadn't physically moved.

    The issue was not with changing frequency on the com radio as I had done so several times successfully before the issue arose.


  • JF Staff

    The volume element of the audio controls has no function as unfortunately P3D doesn't provide control over the volume of each source. In fact the audio selector logic is pretty basic due to those sim limitations.

    The code should:

    • Enable COM2_TRANSMIT if the VHF 2 mic selector is pushed, otherwise enable COM1_TRANSMIT
    • Enable COM_RECEIVE_ALL if the VHF 2 volume is above zero, otherwise disable COM_RECEIVE_ALL (i.e. COM1 receive only)
    • Enable the FS avionics master if the AC emergency or DC essential busbar is powered and the avionics master switches are set to ON, otherwise it will be disabled

    The easiest way to verify correct behaviour would be to add the default radio stack to the panel.cfg as you can then see exactly how the default radio is being controlled by the 146 avionics:

    [Window Titles]
    ...
    Window07=Radio Stack

    ...
    [Window07]
    Background_color=2,2,2
    size_mm=157,270
    position=8
    visible=0
    windowsize_ratio=0.8
    ident=RADIO_STACK_PANEL

    gauge00=Bendix_King_Radio!Bendix-King Radio Audio, 0,0
    gauge01=Bendix_King_Radio!Bendix-King Radio Nav-Comm 1, 0,29
    gauge02=Bendix_King_Radio!Bendix-King Radio Nav-Comm 2, 0,86
    gauge03=Bendix_King_Radio!Bendix-King Radio DME, 0,142
    gauge04=Bendix_King_Radio!Bendix-King Radio Xpndr, 0,179
    gauge05=Bendix_King_Radio!Bendix-King Radio AP, 0,224
    gauge06=Boeing747-400!Nav-GPS Switch, 0, 226, 20, 20