Cannot Start Engines

  • Hi,
    The only way I can start the engines in the Duchess 76 is either by using CTRL-E or the from the start icon on the Panel Selector. I've tried using the on-screen checklist four times between yesterday and today to start the engines but without success. The starter warning lights light briefly and the engine turns over but won't start. I've noticed that the two starter lights are not illuminated after I turn on the Master Battery, should they be? As I use a throttle quadrant with only one lever to control both engines I have mixture full rich and prop full in and throttle around 25% for both engines. I think I may have tried just using the mouse to move the levers for one engine only but engine still fails to start. Is there a step missing from the on-screen checklist, or could I be missing something obvious?

  • This post is deleted!

  • JF Staff

    Have you contacted Just Flight Support with regard to this problem?

  • @PMJ
    I upgraded to the latest version (1.08 I think) and was able to start the engines without a problem, but I only tried the once. I think my problem may have been not advancing the throttle high enough. It is hard to see what "open 1/4 inch" means on the throttle, so I was able to start the engines if I moved it to 25% mark. I only have a single throttle, prop and mixture lever but it works fine starting each engine separately, all you do is advance the mixture and prop full forward, and the throttle 25% and the starter works on each engine in turn.
    Hope this helps you.