Unable to Load Aircraft

  • I have a new laptop with Windows 10 Home x64. I have a fresh install of X-Plane 11 direct install. I have downloaded and copied across the folder from the JF BAe146 Aircraft download zip. X-Plane runs ok, loads the standard aircraft, downloads update including scenery, etc. But it won't load/run the 146 aircraft.

    Basically XP11 gets to the point where it says "Loading Aircraft/JF_BAe_146_v1.0.5/JF_BAe_146_100.scf." and then progress stops. Eventually I hit Ctrl-Alt-Del and Cancel to find windows prompting that XP11 has hung and offering to kill the instance. At least twice I've had to power cycle the laptop. I've tried -200 and -300 aircraft with the same problem. I've tried loading another aircraft (successfully) and then switching across to the JF146 with the same result.

    Any assistance would be appreciated. I've registered a ticket with support as well.

    Thanks, Regards, Ken

  • JF Staff


    I would normally recommend you contact Just Flight Support, but you have already done that so they should be able to help.

  • @KenPascoe Hi Ken, could you attach your log.txt found in the X-plane 11 root directory ? Kind Regards Harry

  • Ok, so as it turns out - my problem was patience. I was giving the progress bar stuck at a certain point 5 minutes to progress. When I gave it nearly ten - it started moving again and the simulation loads.

    My problem now is that the simulation runs for about 5-10 minutes then crashes out, repeatedly. But I will play with it some more and generate some repeatable results, capture the log files and start another post.

    Thanks for the replies.


  • JF Staff


    NB that we can't do support via forums. If you have a problem of any kind, just contact Just Flight support and they can look into it for you.