LNAV issue at the first point of STAR.



  • I've a little issue with the FMS. My navigation gone right until the first point of the STAR, where the AP don't reach the point and do a turn, same way as there was no more point. I have to say the LNAV stays on, on the AP panel. I have to make a direct-to to the first point of the STAR to recover the nav. It made this issue 3 times in 3 flights. Never had this issue with the XPlane FMS, just with the BAe.



  • I had this happen to me today as well. I thought I might not have entered the star correctly initially, but upon further inspection, it was entered correctly.



  • @Boctal Yes, from my side, the FMS was well programmed too, for sure.



  • Hi Cedric,

    I'm one of the developers. I tried to reproduce this issue on my system here, but everything worked correctly. I was able to set up a flight in the FMS from PHOG to PHNL, using the BEACH4 departure procedure, and the JULLE5 arrival, via LNY transition. The autopilot correctly followed the LNAV guidance the entire way.

    So without details I don't know why it wasn't working for you.

    One thing that is easy to overlook are the discontinuities that are added in the flight plane when a departure or arrival is selected. After selecting the arrival, go to the "LEGS" page in the FMS. You can scroll through the pages with the "NEXT PAGE" button.

    The FMS will automatically add a line with 5 "boxes", and the words "DISCONTINUITY" before the start of the procedure. To clear the discontinuity press the line select key next to the next waypoint to enter it into the scratchpad, then press the line select key next to the discontinuity.

    Be sure to press the "EXEC" key to save the changes! I sometimes forget that. This will fill in that gap, so the autopilot can follow the entire flight plan on LNAV mode.



  • Hello, and thank you to taking time to answering me.

    My issue is not about the use of the FMS, flightplan was correctly enter in it, no discontinuity, no vector, nothing like this.

    In fact it seems to be a random issue. I've made two flights yesterday and it works very well. Today I've made a simple flight (LFLL-LFQQ) and it happened.

    I give you the road, may be the issue will occurs :

    LFLL/35L BUSI2N BUSIL A2 PIBAT UM976 BRY UM733 KOPOR UN874 SULEX CMB5D with a transition by ASBAR for the ILS Z 26/LFQQ

    The LNAV has stopped at KOPOR.

    May be you'll be able to reproduce the issue with this road.

    But, I've to admit, I guess it's maybe more an issue with the XP FMS than with the Bae .



  • This post is deleted!


  • Thank you for the details! I'll see if I can reproduce the issue here.

    Though the current version of the BAe is using X-Plane's default FMC, so it is not doing any custom behavior with regards to navigation or LNAV. It is possible this is an X-Plane issue rather than a BAe issue. But I will run some tests and see if I can get it to happen here too.

    [EDIT] I just tried the flight, and the autopilot correctly followed the LNAV course. However, the autopilot turned me left at KOPOR, to follow UN874 in the wrong direction. This might have been because MTD and KOPOR are very close together, so the autopilot knows it isn't able to make the turn.

    You might try flying the same route with one of the default aircraft; it behaves the same way. In conclusion, this appears to be an issue with the route as interpreted by X-Plane's FMC, and not with the BAe.



  • Yup I guess it's the XP FMS too because the AP is working well, LNAV too.