PA28R Arrow III with Garmin GFC500



  • Hi,
    I enjoy fling the PA28R, your product is nice.
    The only problem I have is with the autopilot. Instead of the orginal Piper one I like to fly with the Garmin GFC500. Unfortunately it is not working as expected. I changed the autopilot with plane maker to the GFC700 but I can not select the modes as it should work. I tried it with the standard xplane C172and other aircrafts and everything was fine.
    Is there any chance to change the autopilot?
    Thanks
    Marc



  • Hi @chefpilot,

    I had the same issues as I was planning to use the plane in my sim pit with a KAP 140 autopilot. I changed the AP mode and several other details (like DG source) in the ACF file to match the configuration of my sim pit (Propwash KAP 140, RealSimGear + RealityXP GTN650 & GNS530, selfmade Aspen 1000 EFD). The first issue I ran into was that whenever the AP changed to VS mode (the KAP doesn't have pitch), it would not select the current VS but rather use the previously selected. But this rather seems to be a problem how XP implements the KAP then related to the Just Flight planes. I fixed this with a custom plugin I built myself that will sync the VS every time the VS mode is engaged.

    But the next problem I ran into was directly related to the Just Flight plugins and will likely also be the root for your problems. The plane would work correctly in HDG mode, in NAV mode as long as the GNS/GTN is set to VLOC and would also work in GPSS mode (GTN set to GPS, AP set to HDG, HDG_is_GPSS set to 1 by the Aspen). But it wasn't possible to activate the NAV mode when the GNS/GTN is set to GPS. After playing around a bit I noticed that tracking the GPS would work in NAV mode if the Piper Autocontrol OMNI selector switch in the 3D cockpit is set to OMNI instead of NAV. As soon as it's set to NAV, the autopilot will revert to turn rate mode if the GNS is set to GPS. The problem is that pressing NAV on the KAP 140 (or via Keyboard) will set the OMNI selector to NAV... So the built in AP logic messes around with the modes... a workaround that I'm currently trying and which seems to work is to delete the "AUTO_PILT" directory from plugins\SASL3_Tbient\data\modules\Custom Module in order to remove the corresponding SASL module. This will result in several error messages in the X-Plane log as the plane tries load the corresponding SASL module but it appears as if everything else is still working.

    Best regards
    Florian



  • Hi Florian,
    thank you for your extensive comment. It sounds to be a possible solution and I'll try is as soon as possible.
    However I would like that justflight would offer options for different autopilots.

    Best regards
    Marc