Aeroplane Heaven Fairchild C-119F Flying Boxcar in P3D 5.1



  • I bought this aircraft from Just Flight in January 2019 and enjoyed flying it in FSX. However, I upgraded to P3D v5 in June this year, and recently decided to install the Boxcar in it, as it was allegedly compatible. I'm now running P3D v5.1 HF1. After downloading the 64 bit version from Just Flight, it installed without issue. However, I've found that the programme crashes to desktop whenever this aircraft is selected. I've tried re-downloading it and reinstalling but no good. Anyone know if there's any solution to this, or how to make it compatible with P3D v5?

    Graham