After first time installation no Traffic Global available



  • Hi
    Just bought Traffic Global few days ago. So after executing the installation exe and rebooting PC (Windows 10 64bit) there is no Traffic Global starting. Pressing the x-plane 11 (11.50r3 (build 115033 64-bit) plugin menu entry does not list any like traffic global. So how do I start Traffic global? Kind of basic question I know but I just followd installation instructions and get no running Traffic Global.
    How can I verify what is possibly wrong here?

    Thanks a lot in advance for any help.

    Erathost



  • @erathost April 2021 as I write this, and after the latest update I was emailed about today I have exactly the same issue.
    Downloaded Traffic Global XP 1.0.9997.exe from my account and then the fun starts...
    Have tried the installer, and no plugin listed, tried repair, tried uninstall and reinstall etc etc, all give the same result.
    The files are there. Traffic global aircraft in the aircraft folder, and the plugin in the plugin folder, but it's not listed in the plugin drop down menu of X plane?
    I have never had so many issues with a commercial product as this one. I gave up on the last version as it was crashing to desktop often and thought I would wait until a newer (fixed) version.
    Well today this is supposed to be it, and I can't even see it after installing it!


  • JF Staff

    @Alpha_Hunter

    If you are having a problem your best bet would be to contact Just Flight support. They can help with this kind of thing.

    https://support.justflight.com/support/solutions/folders/17000135782



  • @Derek Hi, was just doing that when you posted.
    As I said before though, I have never had so many issues as I have had with this software, all other software purchased from various suppliers has installed perfectly.
    Even tried on another installation with no plugins added at all, just a bare X-Plane install!
    So weird?


  • JF Staff

    @Alpha_Hunter said in After first time installation no Traffic Global available:

    @Derek Hi, was just doing that when you posted.
    As I said before though, I have never had so many issues as I have had with this software, all other software purchased from various suppliers has installed perfectly.
    Even tried on another installation with no plugins added at all, just a bare X-Plane install!
    So weird?

    Just to be clear, we have not really 'fixed' anything that would resolve a CTD. TG doesn't generally cause CTDs. Mostly they are caused by interaction with outdated plugins. The software is extremely robust (by X-Plane standards) and is our best seller in XP.
    If you have any issues with it you really need to get some help from our support team. You might want to post up in X-Plane.org, but as installation and stability is not really a problem, your best bet is always to contact Just Flight.



  • @Derek

    Well there are several mentions of crash fixes mentioned in the notes for the latest update, so I was hoping mine might have been caught in those fixes.
    Regardless, on further investigation I have found that after the Traffic Global XP 1.0.9997.exe installs, there is NOTHING in the win_x64 folder of the plugin!
    The Traffic Global.xpl is completely missing!?
    That then explains why the plugin is not seen in X-Plane.
    I dug out my old original installer from October 2020, Traffic Global XP 1.0.9672.exe, and (after using the newest to remove the plugin again), used that to install, and yep 'Traffic Global.xpl' is then installed and so the plugin is listed and I can start it, although this is the old one of course.
    Further, trying to update using the new installer 'Traffic Global XP 1.0.9997.exe' results in guess what... Yep it deletes the Traffic Global.xpl file and so no plugin listed!
    As an experiment I had backed up the 'Traffic Global.xpl' file after using the old installer, and I copied that into the new empty win_x64 folder after the new installer deleted it, which then results in the plugin listed and I can start it in X-plane.
    However if the Traffic Global.xpl is the actual core plugin (which I assume it is), and that was updated in the new release, then I am still stuck with the old version with no way to update it. Unless support can send me just the latest 'Traffic Global.xpl' file for me to copy into the win_x64 folder of course.
    It appears then that the new installer 'Traffic Global XP 1.0.9997.exe' is either bugged, or doesn't like my X-Plane install for whatever reason?
    And yes, I will be sending all this information as an addition to my open ticket #51846, but I thought it might give others a heads up if they run into the same problem.
    And no, the repair option of the installer doesn't fix this, for whatever reason the installer does not install this file and deletes it if already there, presumably to replace it with a new one... which it then doesn't!
    Odd huh?


  • JF Staff

    @Alpha_Hunter

    Odd indeed. I still think you should run this by support and adding the information to your open ticket will certainly help. The release of the latest update seems to have gone very smoothly and it has been in test for quite a while now. I think if the installer was broken we would have had some feedback. It may be the location of your version of X-Plane or something similar to that.



  • @Derek
    Well got to the bottom of it.
    Although my Antivirus 'ESET' has no issue with the old 'Traffic Global.xpl' file (or any other in XP11 for that matter), it absolutely hates the new one.
    It quarantines it and reports it as 'A variant of Win64/Packed.Themida.L suspicious application'.
    It not only removes it from the install process, but even while just trying to copy it.
    So for example I have to override ESET to install, then allow it back into the install directory, and then override again after running X-plane the first time after installing, as it kills it again when X-Plane tries to run it. That means running X-Plane, quitting it, override and restore the file then re run X-plane.
    Yep, it's a real pain and going to be a real pain for others if using a similar antivirus, especially a user who doesn't understand how to override and allow it through.
    I have talked to one of your support guys, really nice guy called Simon, he said they will try contacting ESET and others to report the file as a false flag, so to spare other uses issues with it.
    The file is a little larger than the previous version, and something in its signature has changed so is flagging a dangerous file type I guess.
    Meanwhile after all that...Just flew a flight from Bristol to Rome (EGGD - LIRF) as a longish test flight, and so far so good.
    No crashes and it worked perfectly, including using TCAS and even showing traffic on Avitab.
    So fingers crossed!
    Thanks for the help from yourself, and I hope my experience helps others who run into this issue.



  • @Alpha_Hunter Thanks for this. It looks like NOD32 is the only common one with this problem. I have to say I have a low opinion of it; I installed it once on someone's recommendation and it trashed my entire PC, it's the one and only time in decades I've had to do a full restore from backup. Normally you can add a file as an exception, and any sane virus checker would ask you what you want to do with it before just deleting executables.

    Themida is used, but this is a well-known commercial compression and protection utility.