Full flaps gives way too much air resistance

  • Hi Guys, is it only me (x-plane 11.40) or has the TB-20 way too much air resistance on flap 40. When I lower the flaps on final I have to apply almost full throttle to reach the runway. When I pull the throttle back above the threshold the Trinidad stops almost und smashes onto the runway. So I usually land now with flaps 10, which is not recommended in the real plane as you loose the possible gear-not-down warning you get with flaps 40.

  • Hi there,

    You're right, I use the JF TB10 in X-Plane 11.40 and it's a superb rendition in every way except for full flaps!

    Don't know if you're comfortable using Plane Maker.exe, but I've altered the .acf file to make it a lot more realistic (I fly the real thing).

    Back up your 'JF_Socata_TB10+TB20.acf' file, then in Plane Maker.exe, having selected the model in the File menu, go into 'Standard', then 'Control Geometry' and play with the 'Flap and Slat coefficients'.
    I've changed Cl, Cd, and Cm to pretty much zero, which helped, but reducing Flap Deflection (box below) was best. Be careful, everyone time you change one thing, the others alter too, so you may need to check. You'll need to Save your changes in the File Menu and reload the plane. OK, it looks a bit funny in the outside view, but at least I now have reasonable power settings at full flaps.

    Just make sure you've backed up your original .acf file!

  • Hmmmm, I wrote the above before noticing that there was an update available! Having downloaded and installed v1.2a, the full flap situation seems much improved, although still requiring somewhat more throttle than one is used to.

    Still an excellent model, though, and very well worth it, but I still might try tweaking it a bit....šŸ˜€


  • Thanks Dave.
    Unfortunately with this update i get a lot of issues, the pilot is blocking my views, the prop lever and the fuel selector are both not working. And when I switch the power on I get no lights on the annunciator panel and apart from the GPS nothing is working. Even the arrow for the menus is missing, so Iā€™m switching back to version 1.2 šŸ˜ž
    So I guess I have to try plane maker.

  • That is strange, although have you tried simply reloading the aircraft? I've found that with most of JF's complex models, the poor old 'pooter doesn't always get it right first time but a reload always fixes it.

    Didn't even know you could have a pilot sitting in it šŸ¤”

    Best of luck

  • Yeah, I even restarted x-plane several times. Then I went back to the 1.2 version, reinstalled again, same problem. But Iā€™m now playing with plane maker and that seems to work very well.

  • E227B846-16F1-4C78-921E-DAE18BC6E566.jpeg

  • B68E4E4A-5F8F-400A-9010-64236D60F799.jpeg

    That guy is on my prop lever šŸ˜•

  • Ref your issue with the pilot showing, Martyn - Development Manager, mentions this: "Just to confirm, the 3D pilot being visible in the cockpit is an indication that the SASL activation process isn't complete. It usually requires just a restart of XP11".

    If he still won't go away, a simple amendment to the manifest.json file should fix it.

    Back it up first, then open in Notepad. Scroll down a little way to the section "PILOTS" and make sure these, and only these, four entries show 0 (zero):

        "OverrideHidePilots": 0,
        "PilotPosX": 0,
        "PilotPosY": 0,
        "PilotPosZ": 0,

    Save the file and reload the plane.

  • Okay, the pilot is now gone. Still working on the full flap settings. But thanks for now. By the way, it seems you also have the FSX/P3D version, which do you prefer?

  • I think they are both superb renditions, but TBH, I prefer the X-Plane version, not least because the FSX/P3D one has a glitch in the GPS/HSI interface. A ticket has been raised.

    I use it a lot for IFR practice and have the Reality RXP GNS430W installed on both. In the FSX/P3D version, in GPS/RNAV mode, the beam bar in the HSI lacks any sensitivity, so it's a bit difficult to do a precision RNAV/LPV approach! It's fine in VOR/LOC ILS mode.

    I made a work-around by fitting the default FSX (Baron) HSI in place of the Stormscope, but it meant I had to do all my flying from the RH seat!

    The X-Plane version works perfectly, however, and is a pleasure to fly.